Start a new topic

No Wireless interface found on my Pi-Top with RPi3B

Hello,

I've just received my Pi-Top with a pre-installed Raspbian Jessie 8.0 on a 8Gb SD-Card (included in the Kit).


My problem is that No Wireless interface is found in the Icon configuration for WiFi, and I don't know how to make it operate and appear (only ETH0 is shown in the dialog Box).


I've got a second RPi3B with a pre-installed Raspbian Jessie 8.0, on a 8Gb SD Card, and this one works well with WIFi and Bluetooth. The problem is that this distribution does not include the specific software components to access the Pi-Top Hub functionalities (ie no Battery charging information, and no power shut down after a software shut down of Linux.


Does anyone encounters the same problem, and what will be the issue to make the on board RPi3B Wireless interface to appear on the Pi-Top Raspbian distribution?


Also, is ther a way to include battery monitoring and power-off management on another Raspbian distribution not build for Pi-Top? 


Thank you for your Help.


Julien


pi-topOS does support the wireless interface of the Raspberry Pi 3. If you want to use standard Raspbian Jessie on the pi-top, look at github.com/rricharz/pi-top-install

Thank you Rene for your reply, but even if pi-topOS does support the wireless interface, it is still impossible for me to access it (internet connection icon says "No wireless interface found", and a right-click on it sows a menu with "Wifi Networks (dhscpcdui) Settings", but acting on it leads to open a Menu where only Eth0 is available in the ListBox (no Wlan0).


The problem is that connecting an Ethernet Cable is recognized, but I stall can't access to internet, so trying to update with the latest pit-opOS distri fails since It can't connect.


As I explained on my post, the hardware is not the problem since I got all connection (Eth0, Wlan0, and Bluetooth) with another Raspbian distri.


Thanks if someone gots an idea.

This sounds weird because I have recently purchased 2 RPi3s one from RS last year and another from Amazon last week. Both immediately identified my Wi-Fi SSID and I logged in with my password with no problems at all. It could be that the Raspbian is an older kernel preinstalled not to recognise the built-in Wi-Fi of the RPi3 to save space as usual but out of synchronisation with the technical needs of the RPi3 hardware. An offer of the latest version of Raspbian would be a good exploratory step unless you are happy to upgrade the kernel manually as well as the OS of your current Raspbian setup? Other than that, you are getting old stock with the wrong version of Raspbian or very bad luck with x2 RPi3s with broken Wi-Fi circuitry! You are aware that the RPi3 has built-in WiFi?
Login or Signup to post a comment