Start a new topic

How do I disable "Touch Click" on the touchpad

I looked up the Vendor ID for the USB touchpad that serves as the mouse

on the pi-top and it belongs to "EZ Prototypes" but their web site does not

indicate that they sell touchpads, so I could not find any additional information

from the vendor.  If it were a synaptic touch pad there are lots of postings on

how to disable touchpad tap mouse button clicking, but I tried those commands

and they don't work on the EZ Prototypes touchpad.  Does anyone know how

to disable the touchpad tapping mouse click.  I want to only issue a mouse click

when I press the button beneath the touchpad!  I have big fingers and I find it very annoying when the touchpad issues an unwanted mouse click prematurely.


1 person has this question

+1 for this.


1 person likes this

+2 for this.


1 person likes this

Apparently the pi-top OS default configuration utilizes the "evdev" driver to support the trackpad.  I could not find any way to configure the "evdev" driver to disable the touchhpad tapping mouse button clicking.  I may be wrong, but I suspect that this simple default mouse/touchpad driver does not have many bells and whistles.  If the synaptic touchpad driver is compatible (and I don't know weather it is or isn't) then one could load the synaptic driver instead of the evdev driver.  If the synaptic driver is compatible with the EZ Prototypes touchpad, then with the synaptic driver loaded there are options to disable tapping mouse clicks by putting this in the xorg.conf file:

 Option "MaxTapTime" "0"

Or one can call the synaptic support tool "synclient" to alter synaptic touchpad behavior.  But none of these options are possible unless 1) The touchpad is synaptic compatible, 2) The synaptic driver is loaded instead of the evdev driver.  


Hope this helps,  Barry


1 person likes this

I cannot test out the synaptic driver with the pi-top touchpad, because at the moment my pi-top is disassembled and back in the box ready to be returned.  I was dissatisfied with the defective battery so I will be saying goodbye to my the pi-top and this forum.  If anyone else feels like picking up the torch on this issue, I am sure others would thank you for it.  Take Care,  Barry 

+3 on this one.


1 person likes this

+4!  Please disable button emulation on Trackpad -- it is way too sensitive!


2 people like this

+5! Please more work on the Trackpad! 

Login or Signup to post a comment