Start a new topic

Pi3 Bluetooth

Just installed a Pi3 and sdcard supplied by Pi-Top into my pi-top and found the Pi3 appears to be much quicker than the Pi2 it replaced.

To get the Pi3's onboard wi-fi working I had to connect with wired ethernet and then in terminal do:

sudo apt-get update
sudo apt-get upgrade

 followed by a reboot.   


However, I can't get the Pi3's onboard bluetooth to work. I've tried: 

sudo apt-get install pi-bluetooth

which installed the newest version of pi-bluetooth and allowed me to use bluetooth with a USB dongle, but the pi3 internal bluetooth adaptor doesn't appear listed as an adaptor.


Has anybody else got this problem or found a solution? 


5 people have this problem

Same problem here.


I think the answer will be something to do with the fact that the official raspbian Jessie distro uses systemd but the pi-top Jessie distro is still using system v init - I assume that the systemd initialisation of bluez etc is therefore broken on the pi-top distro.


If you look at the output of lsmod, you'll see that some of the relevant bluetooth kernel modules are not being loaded on the pi-top, but manually loading them to match those loaded on a Pi 3 running the official Jessie doesn't solve the problem - there's something wrong with the bluez setup, as it just can't detect the Pi bluetooth hardware as far as I can see, presumably due to system initialisation problems.


The ideal solution would be for the pi-top OS to just migrate to systemd to match the official distro I would have thought.


4 people like this
I fully agree the best solution would be for the pi-top OS to be updated to match the official distro so that users get "out of the box" support for the pi3's on board wi-fi and Bluetooth. It would be good to have a comment from the pi-top team about the likely timeframe for this.

4 people like this

You can get the internal Wi-Fi working using the original green dongle and then setting up the Wi-Fi. Do the apt-get update and upgrade as mentioned  Power down and remove the dongle. power back up and it works. Don't know about the Bluetooth.

My solution:

sudo apt-get install pi-bluetooth blueman bluetooth bluez

Add in /etc/rc.local before exit0 (sudo nano /etc/rc.local)
/usr/bin/hciattach /dev/ttyAMA0 bcm43xx 921600 noflow -

save,exit and give the system a reboot.

Now you should have a bluetooth icon on your Desktop, if not start it from the Menu.

If anyone can make it run with systemd, please respond.
It's in
cat /lib/systemd/system/hciuart.service

 


3 people like this

Thanks Eric, this worked for me!


1 person likes this
To enable bluetooth audio install ;

sudo apt-get install pulseaudio pulseaudio-module-bluetooth pavucontrol

 



1 person likes this

unfortunately I did notice some audio lag of about a second when using the onboard Bluetooth vs a Bluetooth dongle with a Bluetooth headset using an a2dp sink. It works fine with the dongle, but not with the onboard bluetoooth.  I think I  have the resample-rate set to ffmpeg  and not to trivival.  if that matters.

I got my bluetooth speaker up and running with the above tips, but encountered a strange problem. When playing higher rated mp3 or youtube videos with higher audioquality, the output begins to stutter every 1-2 seconds. Looking at the bluetooth controlpanel, i can see that the connection to the speaker is always at 32 kb to the speaker and 1.60 kb from the speaker. I think that the pi doesnt deliver the data fast enough to the buffer in the speaker. Is there any way to confirm this? Speaker is running flawless at my tablets or smartphone.

Markus we seem to be having the same problem.  I am trying to track down a solution now



I've had a reply from my ticket re the issue. It's a software problem which the development team is looking into. They said they'd get back to me when it's resolved.

understood. in the meantime I am using a USB Bluetooth adapter.

I was reading somewhere that forcing core_freq=250 and thus locking the cpu to 600mhz, or setting force_turbo=1, in config.txt, would stabilize the onboard Bluetooth latency issues.  I have NOT found this to be the case with the pi-topOS.


 There is always the possibility that I am doing something wrong with the force_turbo=1 setting.  More testing is required with the setting.  For now, I will go back to using the USB Bluetooth adapter again.


I tested Bluetooth audio again. this time on raspbian Jessie on the pi-top with the latest updates  5-27-2016.  I got the same lag as before on the bluetoth headset (Plantronics backbeats go 2).  I guess I am going back to the USB Bluetooth adapter again....



Are you saying this happens on the latest pi-topOS or on the latest raspbian jessie?
Login or Signup to post a comment