Start a new topic

More International Keyboard Layouts

 Though maybe not a "bug" as such, this misfeature needs higher attention!


7 Months ago the issue about using a French keyboard was raised in the forum but since then nothing seem to have happened by now?


Today I received the Pi-Top CEED I got for my daughters through the Indiegog campaign last year. I immediately connected my (Swedish) keyboard. Logging in was a pain in the but until I realized that the placement of the minus key on my keyboard differ from the selected Uk keyboard.


This can not be that difficult to solve as it is now it feels like I'm back in the early 80s when 7-bit ASCII was the standard of the day...


1 person has this problem

You can open a desktop and use menu -> Preferences -> Raspberry Pi Configuration -> Localisation to set the system to any keyboard you want.
That went well (as already stated in the other thread) Keybaord layout.

When trying the character set in the menu -> Preferences -> Raspberry Pi Configuration -> Localisation -> Keyboard the keyboard is encoded as it should.

However, entering the username & password when trying to log in and using the Notepad in the desktop the characters are still encoded as using a Uk keyboard.

So the problem seem to be with the Pi-Top CEED desktop menu application..

 

Same problem here with my Pi-Top CEED... 

Raspi is configured for german keyboard, the Raspian desktop is working with german keyboard layout. The Pi-Top CEED desktop is configured for german keyboard, too. But the keyboard still works UK-style... :-(  no chance to login with mail address because @-sign is not reachable


I used the Notepad to figure out which key to push to get the character I needed ;) ln my case the uk "-" is located on my Swedish "?"... If i remember correctly the @ is located at alt-3 or maybe alt-4 on the uk (and swedish) keyboard.

same problem here, german keyboard choosen and not working. Layout is still english. Impossible to use this way.


1 person likes this
I get the same problem as Jörg. etc/default keyboard is set to de, within raspi-config keyboard is set to german. Also in the settings of pi-top Dashboard I selected the german keyboard. Within the pi desktop the german keyboard works fine. But within pi-top Coder or Notes on the pi-top Dashboard it works like a US keyboard.

 

i have the same problem like Emilleopold. I'm deeply disappointed about the Pi_top product. does anybody know how to fix. Python coding does not make fun without the special characters. Looks like the pi-top coder is keyboard hard coded. There is a context sensitive menu to switch between UK US and german but it has no effect. already thought about exchanging the keys like in old times. 

Same problem here. German layout but the Pi-topCoder just supports the English Layout. How can i change that? Has somebody found a solution or is this still in progress?

Is there ANY progress with this product at all?

i just got the answer, the problem is known. i'm disappointed because if i had known upfront i would have bought the US keyboard. with this support i don't think i will invest anymore money in here.  


1 person likes this
Login or Signup to post a comment