Start a new topic

Using the Pitop Speaker with a different OS

Hi, sorry if this is a stupid question, I'm very new to working with the Pi, I'm trying to get the Pitop speaker working with retropie, when I do the install from the command line I get the error "E: Unable to locate package pt-speaker" I know I'm missing something but I'm not sure what. Thanks!


guys same question for me aswell, if anyone can help?

The pi-top speaker uses hdmi audio. If you want to use it with another OS, you need to search for how to enable hdmi audio for your OS.
Same here guys, i'm using Pi-top ceed with 2 pi-top speakers and Raspbian. Even after forcing HDMI sound output, it doesn't seem to work.
Just to make sure, i also tried mono and various sound sources.
Is piOS debian based ? If yes, maybe we could just add the repos to apt and install it.

 

See "Setting up the pi- top speaker" in "Tips and tricks". Maybe this helps.

1 person likes this
Thanks for the hint Rene, unfortunately hdmi drive=2 was already uncommented and omxplayer didn't work more.
I'm back on Pi-TopOS for the moment but it doesn' t work more !
I also tried all output types in VLC with no luck. If anyone has a clue, thanks in advance !

 

Despite being a newbie to all this I've trawled the web and found the following. Not sure if I can post the link so have separated it. Read towards the bottom and there's a guide of how to add the relevant bits and pieces to install the pi-top specific files. http: / / www . rs - online . com / designspark / electronics / eng / blog / lorawan - enabling - the - pi - top

1 person likes this
I have done some further investigation into how the pt- speakers work. It is not sufficient to enable hdmi audio output, but the volume of the speaker needs to be set using i2c. See the script /user/bin/pt-speaker, the python script /opt/pt-speaker/pt-speaker-controller.py and the script /opt/pt-speaker/playback.configure

1 person likes this
Thanks a lot to both of you guys! I'll be trying it and report here soon.
Edit :
Thanks to John's finding, i could apt-get install pt-speaker package on Raspbian.

However, i had a look at the scripts Rene pointed out. I read them and tried to execute them from bash. Somehow they keep hanged. Some lines are strangely commented. I tried to edit the scripts by uncommenting some lines and adding some debug prompts, but i'm afraid my knowledge of bash is not yet enough to beat this.

I'll be trying on Pi-Top OS some more, but i doubt that i'll succeed.

Any hints would be appreciated!

Have you done a reboot after the sudo apt-get install pt-speaker? The pt-speaker command gets executed automatically at startup. The corresponding call is in /home/pi/.config/lxsession/LXDE-pi/autostart. If not, put the original files back and reboot your pi. If that does not help, somebody else has to help you because I do not have my speaker available at present.

1 person likes this
I had a response from pi-top curl -sLS http://apt.pi-top.com/add | sudo bash sudo apt-get install -y pt-speaker
@Rene : Yes of course, i did. Well in fact, in Pi-Top OS i tried to run the command «sudo i2cdetect -y 1» to check if any device is detected in the i2c bus. While in raspbian this command succeeds but returns an empty list, in pi-top OS it fails (i2c enabled, packages installed). I guess my last move will be to add the same autostart commands as you mentioned in raspbian to see if i have any success.
Anyway thanks a lot for the hints and answers! If i succeed i will write a how-to, and if i don't, lets try together as soon as you get your speaker!

 


1 person likes this
Glad I could help others out. Mine is working perfectly now in raspbian. I intend to us that and the pi-top os but thought it would be good to use the speaker in a different os.
Well, if that is not too much to ask, could you write down the steps to make it work in raspbian ?

 

The guide is in the link I posted earlier.
Login or Signup to post a comment