Start a new topic

Touchpad pi-top model 2.0

In the beginning the touchpad was working good. After a few weeks there is a problem with using the touchpad. Where the finger is used many times, the black is blinking ( fatt? ), the other black where the finger is not been presented is working normal.

The blinking problem zone can give a click command when it is not allowed.

Is there a software terminal command for not clicking with the move pad, only with the left or right button of the touch pad or can i use a product to clean the touch pad?

Thank you for any advise.


I will investigate this issue a little bit further when I find the time. It would be nice to be able to adjust the trackpad operation a little bit further than what can be done in the mouse section of the Raspbian keyboard and mouse setup menu. In particular I do not like very much that one has to click in the middle of the trackpad to move windows and sliders. But tapping and clicking left and right works fine for me. I just had to increase the double click interval a bit.

1 person likes this
I have investigated this in much detail and have found, that it is not possible to turn off tapping on the pi-top rev 1. The reason is that the touchpad is identified by the driver as a simple mouse with 3 buttons, and does not differentiate between button clicks and taps. There is therefore nothing which can be done at the Raspberry Pi software level to turn off tapping. As soon as I get permanent access to a pi-top rev 2 I will find out how the touchpad is implemented on this new device.
The pi-top rev 2 uses a touchpad from a different vendor, but is also recognized by the driver as a simple mouse with 3 buttons. I cannot see any way to turn tapping off while keeping clicking. I really like the keyboard. It is much better than the keyboard of the pi-top rev 1. The moving and tapping on the new touchpad also works well, but I don‘t like the clicking. If you are used to tapping, clicking is only required for the right click and for drag/drop.

1 person likes this

Seen the same thing: it seems that if there is even a little bit of dirt or oil on the touchpad, that part stops functioning correctly. From not registering movement to unwanted clicks.


Any tips on how to clean or fix it?

One thing which might help a bit is to adjust the double-click interval very carefully: On the desktop, go to menu->Preferences->Keyboard and Mouse and adjust it there. If the value is too small, you cannot double click at all. If is is too large, you will get unwanted double clicks. I am using double tapping and for me a value of 300 works best. With that the touchpad works very well for me. As I said before, I believe that the unerlying Linux operating system uses the touchpad in the standard mouse mode, and all touch taps and gestures are done in the firmware. It is therefore not possible to change the touchpad behavior (other than accelleration, double click speed and scrolling direction). I have checked this and the firmware does not appear to allow to adjust pressure limits in this mode. I have reversed the direction of the two finger scrolling on my pi-top version 2 to what‘s called „natural scrolling“.

2 people like this

Rolling down the sensitivity works perfectly! Awesome!


1 person likes this

Dear Rene Richarz,  I would like to change the scroll direction of the touch pad on my pi-top.  It seems to work the opposite of my Lenovo and Dell laptops.  Make switching between them problematic.


Can you post or email me a hint as to how to do this direction change :-)


Thanks!

Hi Bernard, I looked through my notes and found that the following worked in the past. Unfortunately I cannot try it now because I am on the road. Please let me know whether it works for you or not. Reverse scrolling direction: sudo leafpad /usr/share/X11/xorg.conf.d/40-libinput.conf Add Option „NaturalScrolling“ „true“ to pointer Section

Thank you, that worked great!  Sort of --


I at first entered NaturalScrolling "true" as an "Option" in the pointer section.  That followed the format of the items that were there.  However, after a reboot, I could not log into the RPi, and all paths from the pi-top Dashboard let to a login request.  I had to re-flash the SD and start over.


After I did some searching on X11 scroll, I saw that some "Options" are entered as:

Option "NaturalScrolling" "true"


This works correctly.  I am amazed at the profound ramifications of entering the wrong thing.   Basically hosed the system.  Wow.

Login or Signup to post a comment