Start a new topic

Pi-top v2 Internal USB

My understanding is that the internal usb port can be used for USB sticks etc.  Unfortunately, mine doesn't work for that.  I've tried multiple FAT32 sticks, which are recognised instantly when plugged into the back, but not at all (and not listed with fdisk) when plugged in internally.


The port supplies power, I've tested that with one of those USB fans.


Has anyone else had any issues, found any solutions, or have a working port?




Plugging in a USB drive works for me, instantly and without trouble.  After plugging in a drive, you could try to verify that the drive is connected by using 'lsusb', which shows a list of USB devices that will include

  • Linux foundation root hub
  • Two devices, a hub and the ethernet, from Standard Microsystems Corp
  • The keyboard and trackpad as a device with ID 258a:000c
  • plus any USB devices you have plugged in.

If the drive is not there (though I am loathe to suggest this) you could try checking whether the captive USB plugs that mate with the sockets on the Pi furthest from the ethernet port are making good contact.  One of them is for the keyboard and trackpad, and the other is extended to the internal USB port.  They have been a source of much trouble to me; I improved the situation by bending the plugs gently upwards before installing the Pi, and that seemed to help -- but that is not a solution that has been officially sanctioned.

I am also having issues with the internal USB.


I am running Raspian Stretch (up to date) with all pi top packages installed.


I tried plugging in a Bus Pirate into the rear USB, i can connect via putty and use it just fine. When i connect it to the internal USB, it gets power, but does not mount as a device. Same for USB sticks, their red line comes on showing its powered but they do not get mounted as devices.


Any idea how to resolve this? 

Would love to be using the internal USB (vice running a 2 foot cable around the back of the PiTop...)

Another idea would be to bend inwards the springs on the Pi's USB ports before installing it in the chassis.  That ought to increase the pressure between the captive plugs and the contacts in the port.  It's what I will try next if the problem recurs for me, but since everything is working now, I don't feel inclined to remove the Pi again just to try it.

Thanks for the advice.  I've tried everything, but no luck at all.  Just adds to the overall feel of not-quite-rightness to the whole thing.  I too had the issue with the screw, and the loose rail.  And some sharp corners.

This USB issue is almost but maybe not quite a dealbreaker.  Anyone else had this issue and actually fixed it?  Anyone from Pi-top in here before I raise a ticket or whatever the next step is?

 

Feel free to e-mail me about this: my address is on the page User:Mike at Spivey's Corner.

I'm having the same issue as well. I wanted to store my files on a USB stick hidden inside the pi-top so nothing will happen to them if I have to re- image the SD card again, and this is a bit annoying.


I plugged in a hub with a power light, and it was getting power. Just no data.

That USB concept would make sense. However, who said that "internal usb port can be used for USB sticks"?  Have you seen a specification?  The lack of documentation and lack of technical expertise outside of China can be frustrating. 


I am a Linux developer and used to a much more complete level of support - at least in terms of documentation.



Login or Signup to post a comment