Start a new topic

Raspberry Pi 3 Model B+ using with pi-top

For the Pi-top version 2.

If you use the new Pi 3 model B+, processor is a little bit higher, you need to change the conductive cooling tape thickness, then it will fit.


Pi-top OS is not working although updated via update, upgrade, dist-upgrade, does anybody have an advice?


So at the moment I use standard Raspbian, then it works perfect.


The new Pi 3 model B+ also works fine on my pi-top using the latest Raspbian Stretch and the pi-top device management software (see github.com/rricharz/pi-top-setup for installation instructions). The reason why pi-topOS currently does not work is that the current version of pi-topOS is still using Raspbian Jessie. Just be patient until pi-top has moved their OS to Stretch. They are advertising and selling now the model B+ and therefore a new OS version can be expected rather soon.

I also found that the stock thermal pad was a bit too thick with the Pi 3 B+.

I removed the original pad and replaced it with a thin one I had. I would think a small dab

(very small) of thermal compound would work just as well if you dont have a thin thermal pad.


I also found that Polaris does not run but Raspbian stretch does.


Note: an updated Raspbian stretch was released on March 13 that added support for the Pi 3 B+


2018-03-13:
  * Raspberry Pi 3 B+ support
  * WiFi is disabled until wireless regulatory domain is set (Pi 3 B+ only)
    - The domain can be done through 'Raspberry Pi Configuration' (rc_gui),
      'raspi-config' or by setting 'country=' to an appropriate ISO 3166
      alpha2 country code in /etc/wpa_supplicant/wpa_supplicant.conf.




Login or Signup to post a comment