Start a new topic

Tye-Dye screen on power up

I just got my Pi-Top 24 hours ago and so I followed the instructions and assembled it this morning before I went to work.  It was a lot of fun putting the pieces together!  Of course, when I turned it on, it couldn't work could it?

Here is what it does on power-up.  I've already made a ticket, but I wanted to share it here lest someone else ran into the same problem.

Thanks for your time and help.


(1.59 MB)

I dug in and did some more research namely plugging the RP3B+ into my TV and the same result.  As it turns out, the pitop software DOES NOT WORK with the RP3B+.  I was able to get Raspbian and Kali Linux working.  I'm a total newb - having avoiding linux for decades because I just don't understand it.  I'm trying again, but it sucks when you know nothing and don't know where to start.


I bought a Raspberry Pi 3B+ and tried to use it on the Pi-Top v2 laptop. 

The current issue I am having is that wlan0 and wlan1 is not showing up at all on the interface list when doing an "ifconfig". 

By way of history, when the Pi3B+ was installed, the system froze on the rainbow screen and the power light on the Pi3B+ was signallaling S-O-S. 

I downloaded the Pi-Top Polaris image from . This also failed to boot. 

I had to re-install the Pi3B using the recently flashed Polaris image and issue the following: 

sudo apt update 
sudo apt upgrade 
sudo rpi-update 

I then swapped out the the Pi3B for the Pi3B+ and used the updated SD card. Boots up (Yay!) 
Ethernet interface picked up an IP address but not a gateway :-( 
After setting the interface to dhcp and not manual - wired connectivity is sorted. :-) 

However, wireless interface wlan0 and wlan1 are listed in the configuration but are not listed after an ifconfig. 

So I got past the tye-dye issue and got a network problem.

As a newbie noob of the linux world, I'm beginning to grasp things and actually I was surprised that I understood what you're doing and I think it's a brilliant solution!  My problem is a catch 22 because I don't have any other RP except the 3B+.  Would you be willing to create a copy of your image for me and either make it available to download or put it on a flash drive for me?  I'd be willing to reimburse on some level as I don't expect anything for nothing and when someone helps you out, appreciation should always be shown.

Brilliant solution and tip my hat in your direction.  Way to go!


I should also add that a rep with Pi-Top did contact me in an email and assured me they are working on a compatible version of the Pi-Top OS for the RPB3+.  It will be available to download as soon as they are done with it.  I've got Re4son's version of Kali Linux running on mine with his downloadable image and even though others more in the know have taken issue with it, it works fine for me.  I can surf the net with firefox and use the open office clone software.  I haven't found much else I can do with it other than use it as a learning tool, but with time I'm hopeful I can get off the windows bandwagon.  I don't like where it's going and my disgust mounts slowly each day.  I really really really wish the creator of Irfanview would make a linux version so I didn't have to learn GIMP and I'd like to find an Outlook Express version 6 clone (which I'm running under Windows 7.)  I'm old school and I like my simpler programs without all the bs bloat.  I want my emails downloaded to my machine where I can control them and not be subject to some lethargic, bloated webmail service.  It drives me nuts.  I only mention all of this as its my impetus for switching to the RP3B+/Pi-Top combo.  Back in the day, we referred to people such as myself as a lamer.  I admit that I am, but hopefully by keeping an open mind, I can learn linux enough to keep myself happy and keep my productivity levels high.


Hi Erin,

while you are waiting for the updated Pi-Top OS image, you could (if you like) try out my 64-bit Gentoo image for the RPi3 (available with download instructions on GitHub, at This definitely boots on a 3B+, and there is a Pi-Top variant of the image too - unfortunately, I only own a v1 Pi-Top (the one without the sliding keyboard), so haven't been able to try it on the newer v2 model... but, if you'd like to try it out, I'd be very interested to hear what does or doesn't work!

At the very least, it should get you past the rainbow square / tie-dye screen ^-^

Best. sakaki


Hey thanks for your reply!  I hadn't given any thought about the additional software needed for the pi-top hub so I downloaded your pi-top image.  I'll give it a shot when my sd cards show up later this week.  I couldn't figure out what the different pi-top versions were and thanks to your message, I finally understood that I have the V1 with the piece of sliding plexiglas.  Version 2 looks pretty cool too - more like a traditional laptop would look.  They really need to come up with some kind of add-on to carry the USB ports out to the edge of the pi-top.  I think that would really finish it off nice.  I had to clearance a little bit of plastic on mine so I could get the wireless adapter to plug in the side.


Sakai I downloaded your image and installed it on my RP3B+ and it ran extremely slow.  The green light was on a  LOT and so I tried reflashing the image with no change.  It was still very, very slow like it was immersed in extreme activity from the sdcard.  Any ideas on what I did wrong?



sorry to hear you are having problems with the image. It's had many downloads (including from RPi3B+ users) without issue, so there are only a few things I can think of that might be causing difficulty:

  • What sort of SD card are you using (make / model / capacity)?
  • It is possible that the system is trying to auto-update, if the clock has e.g. been changed more than once (this autoupdate, genup, is supposed to happen only once a week, at midnight, but if for some reason it is triggered at another time, your machine will be busy for 1-2 hours). If you can start the image, and run a terminal (from the task bar at the bottom), and enter the command top (and press Enter), that will show you the CPU load on the system, and what is causing it. Look at the "load average" line, what numbers are showing?
  • To double check, open another terminal window and type pgrep genup and press Enter. What (if anything) is returned?

best, Sakaki

I'm using 64GB cards that are all the same Class 10 SanDisk Extreme Pro.  I'm running Kali Linux on it successfully and even though Kali is supposed to be for pen testing and all that, I've found it to be very quick for what I do.  I'm reinstalling gentoo on the same card so I can follow your instructions and post the results later today.  Thanks for your willingness to help!


I did my checks today and nothing really stood out.  I'm wondering if it's something with these sd cards.  I'm running kali linux on a no-name 32gb card and so I did some research and read an online review of a guy who checked 12 different cards.  He said the fastest was the Samsung 32GB card so I've ordered one.  I installed the new pi-top os and I found it was slower than kali too.  So I'm wondering if it's the card that's the problem even though it's a class 10 and supposed to be fast.  So when this samsung card shows up, I'll try your gentoo image as well as the new pi-top os and see if I get better results.  Kali runs like a lightning bolt compared to the other version and the only difference is the type of card being used.  That makes me wonder if that isn't the issue.


Hi Erin,

yes the make/model of card does seem like one possible issue. I just tried a fresh download and install of the image (the pi-top variant) onto a SanDisk Ultra 16GB card, then booting it in a Pi-Top v1 chassis with an RPi3B+ board, and I wasn't able to reproduce the constant activity LED / slow performance that you reported.

Do let me know if there is still a problem with the newer card.

Best, sakaki

I received my Samsung EVO 32GB card and it is night and day different than the 64GB card.  This card is *FAST* and where normally doing the writes to it from windows with the image was always around 5 to 6 meg a second, this one hits 15 meg pretty solid.  So I wonder why an extreme class 10 card works so blooming slow?  I just bought several of them so I could experiment with different images, so it looks like I simply bought turtles.  I guess I can use them for file storage or something like that, but CLASS 10 extreme my foot - they are SLOW!!!  Gentoo was actually usable and so now I'm putting on the new pitop image and going to monkey around with it.  What a nice treat to actually have the pitop power down on it's own instead of having to wait for it to close up shop then push and hold the button to finish shutting it down.  Still, the Kali Linux version from Re4son ran really well with it and I was able to pen test my network where at home really well.  


Glad to hear the image is now running OK for you ^-^

Not sure what is up with your original 64GB card though - there are quite a few fakes knocking around, unfortunately.

Best, sakaki

Login or Signup to post a comment