Start a new topic

Sudden loss of screen brightness

I've suddenly had an issue where my Pi-Top will boot up an then Ill get the Pi-Top loading screen, but the screen will loose its brightness and go nearly completely black (to the point where I cant see my cursor to make changes). 


Any thoughts? 


Has anybody seen this issue before?


3 people have this problem

Thanks Dave for replying.  Lack of any resolution or interdiction from anyone from Pi-Top is not promising!.

I'm thinking that the Pi-Top team screwed up the last but one update - that I obtained by apt-get dist-upgrade.  During the download the screen brightness suddenly changed - to about maximum I believe, before getting anywhere near kernel updates.  That was the update that installed PIXEL and the new Dashboard.  The Pi-Top team updated pt-hub-controller and lightdm.conf that were changes in the configurable pi-top hub, and it seems they tripped something about backlighting therein, dependencies screwed-up most likely.   Because the RaspPi works perfectly well out of the Pi-Top.   They seem to be aware of this and have issued a complete new Raspbian with Pi-Top extensions - but I've now downloaded that and tried that too and it doesn't reset the hub (or otherwise switch the backlight on again).    

Looks as though we need to get in touch with Pi-Top directly - this forum support is going nowhere. 


2 people like this

 I bought mine a few days ago, i disabled the xorg screen saver in pitop and this solved my problem, however they just released an update today with a new pitop dashboard and I LOVE IT! works smooth, it dims the screen properly now, and I like how it has the shortcuts to google services on the laucher! what can i say pitop just keeps getting better!


1 person likes this
You can certainly try to boot with a Raspbian Pixel SD card. This will work well unless the hub controller is stuck with brightness set to zero or backlight turned off. If that is the case, it is more difficult to recover.

1 person likes this

Help! Is there any way I can shutdown safely when the screen has lost brightness? I can't see enough to do it properly.

I'm having the same issue.  Any solutions?

 

I'm coming back to play with the Pi-Top after much frustration. I upgraded to a Pi3 and downloaded the latest PiTopOS. Screen still goes blank after boot up. Moving mouse or pressing a key doesn't help. I do get a message saying the Xscreenscaver is out of date. 


Can some point me to the patch  fix referenced above?

Brian I have similar issues, spend hours getting the top working then normally just when i am happy, the next boot does not happen! One option was like yours I can see PITop logo as it boots then a faint image on the screen. But not possible to work. brightness  option mostly does not work. Currently using Raspbian instead.
Also had it one day when battery was dead with pitopos but changed to Raspbian and it charged..
 

 

The update to the Polaris OS which came out a week or so ago seems to have sorted it, so that's probably the best way to proceed.

 

I am in the process of sorting it out now.  seems commenting out over_voltage =2 in config.txt had something to do with the undervoltage warning at boot.  I've re-added that back and put the pi's power settings in powersave mode (cpufrequtils).  I am still testing.  before I re-added the over voltage back in, videos would randomly darken and relighten the screen and my tv tuner in kodi would do that as well as sending a random shutown signal to the pi. 


I also reseated all cables just to be sure.  I will test kodi and my hdhomerun again today though and leave a message here after i do so.


just tested completely with a couple of DVDs in Kodi.  all issues in the message posted earlier seem to be fixed.  therewe re no random screen issues and n random shutdowns of the pi-top.  could have been the under voltage or a bad or loose cable was causing the issues. 

since a small movement of the mouse is fixing this on my Pi-Top i guess it is a to fast screen saver. :)

 

No, its definitely not the screen saver. I can still see the text on the screen, but its so dark I can't tell where the mouse cursor is, so it becomes un-usable and it does this almost immediately after the Pi-Top begins to load just after start up.


Im not 100% sure, but banging on it a bit seemed to fix it.  Maybe my mouse pad came loose. 


I have tracked down the issue.  will post in thread  ""pt-hub-controller Kodi bug""

Login or Signup to post a comment