Start a new topic

WiFi Not Working properly in Pi-TOP

Hi and thanks for making the Pi-Top possible. It is a great project and I hope in the next version you guys and gals will do great things with it. 

Built the Pi-Top within a hour. However, the pi-Top won't allow me to access my AC WiFi network running WEP2 with a AirPort Extreme. If I run it open, I can get on with no problem. Anybody with an idea of what I am talking about know what is going on there?

Is the including WiFi dongle capable of True N or AC? How can we do a proper substitution without breaking too much?

Could we have a section where we can troubleshoot the growing problems out of the Pi-Top so we can grow into a stable Beta we can use?


1 person has this problem

I have the same problem. Have you found a solution?

I've just built my pi-top. It didn't include a wifi dongle, presumably because it's the pi 3 which has onboard wifi. However, I can't get it to connect to either my iPhone hotspot or my mifi dongle. I tried my wi-pi (from an earlier pi) and it won't connect either. Any suggestions?

Same problem here.  Ethernet is working fine, though.  I'm typing this on the pi-top with the Raspberry  3.  Is there a missing driver or something?

Solved it updating to newest possible image. Either Sudo apt-get update && sudo apt-get upgrade then && sudo apt-get dist-upgrade. Or burn newest image


i used another wifi dongle and it worked

after registering i tried the provided dongle

it worked

My pi3 wifi works ok using Raspbian, but not with pi-top Jessie. I downloaded the latest version, but it just won't connect. If I log in as guest, I still can't access wifi, either the onboard or using a dongle.

Got the same issue here with Pi 3 and the built in wifi. Should I switch to an external adapter?

Got connected to my wifi but no internet access?? Ideas anyone?

1 person likes this

Hi Ken,

Sorry to see that you did not get an answer since 4 days, and I don't know whether you have any experience with a rpi.

Some versions of Raspian and pi-topOS have various problems with the built in wifi of the rpi 3. I would try the following:

If you have access to a wifi dongle, hook it up and try to access the Internet. If not, hook up the rpi with a network cable directly to your router. Boot your rpi and go to the desktop. Connect to the internet. If that works, do a software upgrade using the following commands:


Check whether there is sufficient free space on the disk in /dev/root. If yes, proceed with

sudo apt-get update

sudo apt-get upgrade

This will take a long time. On my system it did not screw up anything on my pi-topOS. Once it is completed, you can remove the network cable or the dongle and boot up again. You should now be able to connect to the internet.

If it all fails, you need to download the newest version of pi-topOS using a PC or MAC, and write it to an SD card. Just ask again if you have any further questions.

Regards, Rene

Hi Rene,

Yes I do have PI experience in the past with PI 1. l always got it and dare I say my Beagle Bones all connected to the internet with no problems. Yesterday I put on an external wifi adapter, still can access my net, can ping etc but cant get to net. I downloaded the new OS and just got it transfered to a 64 gig sd but havent tried it yet.

I did an ifconfig -a and saw the ip I set for it. Can also see the PItop from Windows using advanced ip scanner. I set wpa_supplicant to my wireless router and also network interface to hotplug wlan0 with static ip. Anything else needs set/modified?

Sorry for delay in answering but could not get logged in here yesterday...

If anyone is following this thread I will report my issue resolved. Everything is resolved and working as it should. P rob was with wpa_supplicant.conf. Edited this out of the interfaces and rebooted. It works!!

Sorry for hi jacking this thread...

I have spent 4 hrs trying what is on this thread and I still cannot get the wifi working.

It is a Pi 3 out of the box into Pi-Top out of the box.  It should work.

1 person likes this

You could try adding a Wifi usb dongle to get it set up then remove it and the inbuilt should start working. There looks to be a lot of issues with the Pi3 and Wifi.

I just got a Pi3 after having a pi1 and being unable to use the PiTop OS. Now I'm running into a lot of issues. The wifi freezes when trying to set up with the provided dongle. If I skip wifi setup, the screen freezes as soon as I finish the "tutorial". I can't do anything using the pitop...

I updated my pitop os to the latest version jessie release. The version I had before that wouldn't boot at all, so I assume a file might have been corrupted in provided pitop os image...

Any ideas on resolution?

Login or Signup to post a comment