Start a new topic

WiFi Not Working properly in Pi-TOP

Hi and thanks for making the Pi-Top possible. It is a great project and I hope in the next version you guys and gals will do great things with it. 


Built the Pi-Top within a hour. However, the pi-Top won't allow me to access my AC WiFi network running WEP2 with a AirPort Extreme. If I run it open, I can get on with no problem. Anybody with an idea of what I am talking about know what is going on there?


Is the including WiFi dongle capable of True N or AC? How can we do a proper substitution without breaking too much?


Could we have a section where we can troubleshoot the growing problems out of the Pi-Top so we can grow into a stable Beta we can use?


Adam




1 person has this problem

Try it without the dongle. Pi3 has its own built-in wifi.

Unfortunately, that didn't help. It still freezes when trying to set up wifi.

I have a similar problem. Using am Airport Extreme router and a RPi 3 in the Pi Top. It logs on my network, but won't connect with anything because it keeps asking for a Pre Shared Key. I looked up the PSK with my Airport app and I have the key, but it fails when I try to enter it - says it might be too short! I also tried using the RPi with an Edimax dongle, but I get the same result. Anyone have any suggestions?


When you set up your Pi-Top / CEED also make sure your 'WIFI country code' is set to your corresponding country - best done by doing [sudo raspi-config] in terminal but can also be adjusted in the settings in control panel menu desktop ; both require reboot !!
When pi-top CEED first arrived wifi was set-up no problem. I have since had to reflash SD 3 times buying 2 new cards and ran all updates/upgrades ...
(all upgrades caused problems which resulted in frozen and unresponsive pi3 for over 12 hours!! turned off at power and resulting kernel panics when powered up again so I have decided against any upgrades or dist-upgrades for the foreseeable1! lol)
... using wired ethernet connectionNow updates completed unplugged ethernet rebooted , configured wireless which was actually also done as part of start-up with newly flashed SD, and I am unable to get wireless connection. I do notice the ethernet icon in system tray as opposed to the wireless icon I had before i ever plugged in ethernet
Any suggestions as how to get wifi back again??so long as it DOES NOT involve an upgrade11 lol. I can't handle another series of having to order new card reflash etc etc

 

On first boot you HAVE TO go into raspi-config (terminal) to set WiFi - Country to U.K. and reboot (or whatever country you're in). WiFi and Dashboard login will NOT work otherwise. In theory you should be able to do it from preferences menu in Desktop but not working so sudo raspi-config only way.
Login or Signup to post a comment