Start a new topic

Battery / Power problems

When my Pi-top is charged I'd unplug it from the wall but immediately the pi top would turn off. For a while all i'd have to do is try to remember to shut down when its charged then unplug it. However, perhaps i forgot to do that one to many times now I get no indication of battery charge, nor does the pi top power up without being plugged into the wall. Its become highly inconvenient and Im not sure whats damaged or how to fix it, what can be done?Thank you very much


22 people have this problem

Many thanks for that Stuart! That's more help than I've ever received from pi-top!

I'll give this a try and let you know how I get on.


Thanks again,

Liam

I've tried the pt-battery-fw_update_v2 now but without success. I just get error number 5 (whatever that means) every time I run the executable. I appreciate your help though Stuart.


Personally, given my experience with pi-top, I think I'm now going to approach UK trading standards about their product, and I'd encourage other pi-top owners with broken kit that has not been replaced or fixed to do the same.


1 person likes this

There is no fix Liam, even if you get a replacement unit.  My unit is a March production unit, received in April, and the battery issue started first day of use.  If they had a fix like they claimed they had months ago, they would ensure the units they are shipping are fixed.


So if you get a replacement unit, best you can hope for is that you always keep the unit plugged in so that the battery never goes wonky.  Remember, even when the unit is turned off, the battery is alive supplying power on the 3.3v rail.  Which means, you can't simply "not use the device".  The battery will drain and when it does, your issue is back.  Only way to ensure your unit doesn't go wonky is that you leave it plugged in AC 24/7/365.


Great design eh?


1 person likes this

@Dylan - very interesting to hear of your experience - I'd wondered about the situation with more recently produced units, and it's worrisome to hear that the battery problems are still present - the pi-top is being heavily promoted and marketed, and I wonder where this sorry situation is headed as there are going to be increasing numbers of dissatisfied customers looking for help with their non-charging pi-tops. This just reinforces my view that there is a genuine trading standards issue here, and I'll be approaching my local trading standards office next week.

yeah.  my relacement base was charging fine (received in april).  I fully discharged it two days ago as a test.  now the replacement base/battery won't charge.  also the first unt i received never woke from sleep. 

----Jesse Moore

 

oops my replacement base was recieved in february or march, not april.

---Jesse Moore

 

I posted my battery issue in another thread, but here is the summary of the issue.


Got the unit on a Friday, assembled Saturday morning (using Pi3).  When plugged in and testing for the first time, spent about an hour using the unit.  It was warm in the bottom left corner (thus it was charging).  After I was done testing things out for the hour I wanted to "test" the battery, so unplugged the AC while the unit was one.  Unit remained up without issue.  Was happy with that test.  I needed to go out, so I "shutdown the unit" using shutdown now -h.  Confirmed the pi3 was powered down and unit was "fully off".  I didn't want to leave it plugged in charging while I was out, so I left it unplugged.  Went out and came back 3 hours later, went to plug it in and test the unit some more.  After two hours of testing, noticed no warmth in that lower left corner.  I knew from reading about all the problems in this forum regarding the battery to know I just ran into this issue.  I did do some further testing such as trying to run off the battery, trying to start the unit of battery, resetting the hub, etc.  I knew it was on vain.


I opened a support ticket and not surprisingly the response was "known issue" and "patch very soon".  Having read threads citing the exact same issue that were "2+ months" old with the same solution "patch shortly", I pretty much wrote the unit off as a real laptop at that point.


Wasn't my own issue.  My unit did not come with any screws in the base unit that are supposed to be used to tighten the screen hinge.  I opened a support ticket and eventually they sent a bag of screws, but neither of the two I am missing that the unit is supposed to have already in the screw holes in the base.


I have a 13min video of my unit and overview of it.  Youtube keeps thinking the video is only 6.5 mins, so when I get it uploaded correctly, I'll post a link to it.

I cannot provide any help if you have already been running into this issue, but the following suggestions might be of help to avoid it. I am not affiliated with pi-top in ay way other than owning a pi-top.


First, make sure that the pi-top-hub is properly turned off when the rpi is shut down. Open a terminal and type "sudo shutdown -h now". The rpi will now shut down. Make sure that the red light on the rpi also goes out.


Next, see the separate thread "battery status display" and install the program gtk_battery. It will attempt to shut off the rpi and the hub if the battery capacity falls below 10 %. It uses the command "sudo shutdown -h now". Furthermore it shows you the battery capacity and status if you are using the desktop and gives you a warning if the capacity falls below 15 %. It also logs all activities.


Furthermore, make sure that you have nothing connected to the persistent 3.3 V pin of the pi-top-hub, and that the battery has been charged sufficiently before leaving the pi for weeks without power.

as I said in the other battery thread, I got the battery firmware version 2 patch to take on the third charge/full discharge cycle.


there is hope for the battery....


---Jesse Moore

I have the dame problem with my Pitop. I have posted a ticket. Wait and see....

Posted a ticket on the issue, but the answer was not satisfactory at all:


"Hi Marco,


Thank you for getting in touch with us.


If you would like to ensure that no power is being supplied to the Raspberry Pi then please remove the micro USB going into the Raspberry Pi.

 

If you have any other questions please feel free to get in touch with us.


Thank you.


All the best,


Alan"



The permanent 3v3 rail drains the battery quickly even if the PiTop is off, especially if you have an external drive connected (a WDPi in my case). The quick workaround is to add a physical switch to completely cut power from the RPi. This is the least invasive solution, I ended up severing the 3v3 connection altogether. I had to patch the board to ensure that power is fully cut from the RPi when the system is off.

Hi Marco, I don't understand what you are saying here. How should the permanent 3.3 V be connected to the rpi? I believe there is no permanent 3.3 V connection between the hub controller and the rpi. How are you shutting down your rpi? Which OS are you using? Does the red light on the rpi go off if you shut down?

Hi Rene,

there is a 3v3 "permanent" pin on the pi hub. I've noticed that even when RPi is completely off there is power connected on that pin. BTW I'm on the latest PiTopOS and usually I use the regular shutdown from the menu, sometimes I'm in terminal and I "shutdown -h now". YMMV.


Your shutdown methods are fine.


The permanent 3.3V connection on the hub controller does not go anywhere as far as I can see. It is permanent and should therefore not be connected to anything.


My pi-top battery lasts several months, if the pi-top has been properly shut down, without disconnecting anything, even so I have permanently connected a usb stick.


Reasons for loosing power quickly after a shutdown are as far as I can see are the following:


1. Not properly shutting down the hub. The red led on the rpi remains on, the hub keeps delivering 5 V, which is consumed by the rpi and whatever is connected on the usb connectors.


2. Accidentally the pi-top is turned on again during transport. I have seen this happening several times.


In my opinion the best way to avoid draining the battery completely is the following:


1. Never connect anything to the permanent 3.3 V


2. Check whether the red led is gone out after every shutdown


3. Install my battery widget, which does not only display the battery capacity on the desktop, but also shuts down the rpi properly if the battery capacity falls below a set limit. See

  github.com/rricharz/pi-top-battery-status

Thanks for the suggestions Rene, I actually have your widget installed. I am positive that the shutdown is proper (no light on).

I will measure the current on the pitop hub usb connector and again on the header pins and report back.

At first I thought it was my custom addon board, but even with that removed I still experience the drain. 

Login or Signup to post a comment