Start a new topic

Battery / Power problems

When my Pi-top is charged I'd unplug it from the wall but immediately the pi top would turn off. For a while all i'd have to do is try to remember to shut down when its charged then unplug it. However, perhaps i forgot to do that one to many times now I get no indication of battery charge, nor does the pi top power up without being plugged into the wall. Its become highly inconvenient and Im not sure whats damaged or how to fix it, what can be done?Thank you very much


22 people have this problem

If you have my battery widget installed, you can also look at the history of the battery capacity in the file batteryLog.txt in your home directory. Maybe that helps to understand the problem. But be aware that the time stamp of the first entry after each bootup might be wrong because the rpi needs to fetch the current date and time over the internet.


Looking forward to hear back from you.


Just a note this is still happening.  I started hitting this a month or so ago and am just now able to spend time troubleshooting.  FWIW, the link to the V2 files on amazonAWS give me a "Forbidden" error  so I can't install them.

I have done both a distribution upgrade and system firmware upgrade.  At this point the pitop is pretty much useless as a laptop. 

Does CEED ever publicly comment on updates?  If so, where do they do that?




 

Yes, it's a known problem and often times the firmware update for the battery fails to install, especially if the battery is already completely dead and won't charge. The solution they provided me was to replace the pitop base. you'll need to contact them to have new part sent. The new base ships with new firmware installed already and I haven't had any problems from it.

I'm in the same boat.  I opened a support ticket immediately when I got my unit.  They closed it citing a software fix was coming.  Software fix never worked for me and I never got a replacement battery.


I tried opening another ticket now but I doubt it will lead to anything.

Yeah, I figure it's a write off at this point.  Frankly, my unit is well over a year old and I always considered this a toy (compared to anything actually useful).  Still, it would be nice to have it working as a project box again.

 

I just bought this as a gift for my son right for Christmas.  I had this problem for a week now and just send them the e-mail.  Waiting to see the how to solve the problem.

Had my pitop little over a week and won't run off battery power. pt-battery returns the following: State: Charging Remaining time: Error Notice other people of the forum have the same issue. Also the hub won't auto power off night before. Holding the power button in for 5 seconds didn't cut the power either. Had to take the hub out the battery. Raised a ticket to match this.

Now on my 3rd recovery from this battery issue.

Whether the pi-top is on or off, the battery will not take a charge. The pi-top will run off the battery though....

You can run through this procedure to find out what does not work: github.com/rricharz/pi-top-battery-status/blob/master/battery_problems.md

I finally received a replacement bottom base after reporting battery wasn't working 0.5 days after receiving the original.  My original base didn't include the hinge mechanism either, which I reported but got no where with.  


How can we check if the battery is the revised one with the proper number of cells without opening it?

How can you tell if the base is a revised one with proper number of cells/

FWIW, I finally got a replacement battery but it only lasted about 6 weeks before bricking itself.  The keyboard has also messed up - the I and O keys both press with either is pressed, along with , and . and also K and L.  Considering how long it was bricked, I am surprised about the keyboard.  If any of the keys even had more than 1000 presses I would be amazed - it really was a light use type of project.

At this point the pi-top is fairly useless, even as a demo to others of what might be possible.

I put it into the "This is a toy and nothing more" and have moved on.  The display might be salvageable but I learned a fairly expensive lesson here...  I wish I had better news.

 

Same problem here

Hi, I have 3 pi-tops of which the keyboards get better with the day. They are original ones, never got swapped. I've spent about a year to try and create sort of a battery test program. Alas, that attempt failed because of the unreliable SMbus communication between the Smart Battery Module and the RPi. I use a pi-topPROTO board to connect a Texas Instruments EV2400 (SMbus to USB Convertor)(quite expensive!) and Texas Instruments Battery Management Studio on a PC. On condition that the RPi is uncoupled from the Hub, that is a safe procedure. Texas Instruments Technical Reference Manual for the bq40z60 is mandatory (.pdf file on TI's web site). It's a lot of studying on a high level. Please refrain from changing any value until you fully know what you are doing. When the Smart Battery Module has switched off the battery cells and signals a Fatal Error, trying to override that condition is asking for trouble. Please read and understand the stuff on Battery University's web site. Regards, Ivo. ps: 4 Honcell Battery cells, rated for 2900mAh, nominal 3.7 volt (3.0 - 4.2 volt).

Login or Signup to post a comment