Start a new topic

new pi-top jessie image

If you've downloaded the new pi-topOS image based on Raspbian Jessie, and you're using a Mac, you may have encountered some difficulty in decompressing the image using the usual unzip tool:


skipping: pi-topOS-jessie.img          need PK compat.  v4.5 (can do v2.1)

The solution is to download the p7zip utility, which you can download and install via either MacPorts or Homebrew (search Google for these, if they're new to you):

sudo port install p7zip (MacPorts)


brew install p7zip (Homebrew)

then to unzip the file:

7za x

that should do the job, and you should find as the output of this operation a file called pi-topOS-jessie.img which you can then flash to your SD card in the usual way.

I hope this helps someone else out there!

Good luck!

I am having a problem flashing the image. I run in the terminal on a Mac "sudo dd bs=1m if=pi-topOS-jessie.img of=/dev/rdisk3s1"

It writes the data, but nothing happens when I insert the sd card in the Pi. It is also unmountable on my Mac.

Hello David - there's a really clear set of instructions on writing disk images to SD cards on the official raspberry pi site - I don't think this forum allows posting of links, so I'll spell out the location of the guide which covers Mac as well as Windows and Linux:

wwwDOTraspberrypiDOTorg / documentation / installation / installing-images / 

Hope that helps you get sorted!

I am experiencing the same problems as well but on a Windows.

Followed the instructions and it was how I did it the first time I got the Pi-Top but now the thing will not boot and all I get is a lighted blank screen...

Any ideas? The green LED does not blink so looks like nothing is happening...

wait... found the issue.

Under boot, config.txt once I uncomment the forcehotplug it worked.


change to 


Login or Signup to post a comment