Start a new topic

Kernel Panic/Where to find image downloads


I received my Pi-Top in December along with the supplied 8GB microSD card with  Pi-TopOS already on it.  Due to a fault with the Pi-Top I had to wait for some replacement parts and so have only just been able to put it together.

When it first booted it went straight to the Dashboard and it told me to run an update.  This only ever showed as "connecting" and never went any further.  I was also never able to login using my Pi-Top login details as it just hung at connecting again.  I was able to bypass the Dashboard and go straight to the LXDE desktop though.  I found the support article regarding running the patch, so went ahead and did this, which resulted in the Dashboard update successfully running.  However, after this the Dashboard died and has not worked since, claims it is not even locatable when I use the shortcut key.

I then saw the post that there was a new Jessie image available, with a link provided by another user to download this from the Pi-Top site.  I went ahead and grabbed it and have written it to my SD card using dd.  However, I now cannot boot at all as there is a kernel panic and everything just stops.  I have tried downloading the file again in case it was corrupt and have rewritten it multiple times, still with the same issue.

I'm at a loss at to what to do now.  I have been scouring the Pi-Top website, support areas, Reddit and Facebook info along with any third party discussions I can find.  I really like the concept of this project and I do like the Pi-Top a lot but I think it is very let down by a serious lack of information and communication from the Pi-Top team.  There is nowhere visible to download the Pi-TopOS images, either current or previous versions.  The support and forum areas are very lacklustre with little content, information and discussion.  I don't feel that the official activity on the Facebook page and in the media releases is matched by the support to users once they have actually bought the device.  I also see that questions regarding future batch shippings by interested buyers or other sales queries are answered by official team members while genuine calls for help go unanswered other than by users who do their best.  I am concerned that I have bought into a product that has had a lot of hype and fanfare but is basically dead in the water.

If anyone can point me in the direction of a working image or solution, please let me know.  Thank you.

Not sure what you mean by dd. If you use Win32DiskImager (assuming you are using a windows machine) to burn the unzipped image file you should be ok. If you look at the site you can find instructions about burning images

dd is a Linux command line tool with a number of uses, one of which is for writing an IMG or ISO file to an SD card. I don't even have Windows, only use Linux and BSD based systems. I'm fine writing images to cards, I have Pi2s all round the house configured as media devices, cameras, home automation controllers and more. Pi-TopOS itself just will not fully boot, it craps out with a kernel panic. I'm only using the equipment delivered with the Pi-Top and it booted fine with the previous Wheezy image, though that was broken in its own way. The Jessie image just refuses to boot. I'm going to try using an Arch Linux ARM image instead, as that is my main OS on my desktop.
Login or Signup to post a comment