Start a new topic

Pi3 Bluetooth

Just installed a Pi3 and sdcard supplied by Pi-Top into my pi-top and found the Pi3 appears to be much quicker than the Pi2 it replaced.

To get the Pi3's onboard wi-fi working I had to connect with wired ethernet and then in terminal do:

sudo apt-get update
sudo apt-get upgrade

 followed by a reboot.   


However, I can't get the Pi3's onboard bluetooth to work. I've tried: 

sudo apt-get install pi-bluetooth

which installed the newest version of pi-bluetooth and allowed me to use bluetooth with a USB dongle, but the pi3 internal bluetooth adaptor doesn't appear listed as an adaptor.


Has anybody else got this problem or found a solution? 


5 people have this problem

i know have the latest and greatest pi-topOS 12/02/16 and the bluetooth has gotten way far but it is no connecting to my samsung bluetooth sound bar it says I need to go to the audio menu to connect. So I download pulse audio but that says fatal error! any ideas?

Should Bluetooth with RPI3 out of the box with 2016-09-30-pi-topOS?

Just tested the logitech Dinovo Edge Bluetooth keyboard with PIXEL the newest Pi-topOS without needing to install blueman or reinstall pi-bluettooth.  I am using a usb bluetooth adapter though.

 I had to type the pairing code once then type in a second code when it requested it.  but....


It paired fine and woks.


I will retest with the Pi zero board. but it should work. 

I am actually having a similar issue with Pixel and a logitech Dinovo edge bluetooth keyboard.  The keyboard worked fine and connected O.K. on an install of Raspbian Jessie (5-23-16 i think) on a pi zero (not relevant to the forums, I know!).  I tried updating that image to Pixel, and the keyboard wouldn't connect anymore.  I also tried a fresh image of raspbian pixel,  keyboard still won't connect. 


After I get the pi-top updated, I will see if I can track this issue down  as I said, I know it's not relevant to the forums, but its the same OS. 


---Jesse Moore

@rene. yup I followed those to a 't' but the pairing still appears to fail
So I ran through it again and now have what appears to be a connection (little icons red green blue) flashing and saying connected
So I opened bluetooth devices dialogue , I see my 1byone keyboard , I right click and pair, then icons appear orange green and blue, signal strength and link quality optimal (All promising appears to be working), BUT when i try to type something into terminal for example using the keyboard or move the mouse nothing happens!
Also the icons disappear after about 20 seconds and the device appears to no longer be paired
I do have WiFi on at the moment, could this be the issue with sharing BT and wifi internally or is that fixed?

Dave

 

Maybe the manual of your keyboard explains how the pairing process is supposed to work.
So just installed latest pi-topOS 30/09/2016
After which installed pi-bluetooth bluez blue-firmware blueman etc as suggested by support
I also purchased a BT dongle
SO now I have bluetooth icon, all seems fine...except when i try to pair my bluetooth keyboard ....wait for it....IT FAILS!!
At least now it is seeing other devices etc, just the pairing not working??
anyone any ideas?
When i get the passcode/PIN I just type it into the keyboard although that seems a bit weird?? surely it would have to be paired in order to accept the input (Oh I dunno just thinking out loud!)
Help appreciated. I have given up for now on internal bluetooth especailly in combination with WiFi which I have working fine
Dave

 

oh, and erik's post above will get the bluetooth  working, but won't solve the audio lag.



@ G Lawrence,


umm look at my file up above in the other pi bluetooth  thread.  once you get the bluetooth adapter working, it may still not be useable.  If you use the onboard wifi and the onboard bluetooth at the same time, the bluetooth audio wil lag behind about a second or so.  there doesn't appear to be enough bandwidth on the bus that the combo chip uses.  get a separate usb bluetooth dongle.  this is the best solution for now. 


have fun,


---Jesse




I am also having an issue with bluetooth, (no adapter available). I am running pi-top OS updated to Pixel. My speaker works well, boots quick runs steady. I just cannot use my bluetooth accessories (headphones, speakers etc).


I have done everything suggested by Erik and others here and nothing has worked. The bluetooth icon appears the bluetooth menu appears but it says "no default controller available" and "no adaptors found" when i try to scan for devices either via terminal or GUI. Contacted pi-top who sent me a link to an article in CNET about getting bluetooth up and running with Pi3, followed along and just those errors about controller and no adaptors. I am wondering if maybe I have a broken Pi3? Can anyone confirm they where able to pair a keyboard with the onboard BT chip on the Pi3??? (P.S I know the keyboard is working as have paired it with other devices ;)

 


1 person likes this

Please read Erik's post in this thread it's the fourth post on page one.  it is how you get bluetooth working on the pi-top.


sorry, I didn't feel likie reposting his material.


---Jesse 


1 person likes this

i have read every article on getting the Bluetooth working and the on board adapter doesn't seen to show up please help.


1 person likes this

I had the issue with Bluetooth not identifying the adapter on pi-topOS. I then started with a fresh install of Raspbian and got bluetooth working under raspbian, to make sure my bluetooth was working properly. 


Then i installed the repos for pt-battery and pt-hub. As soon as I installed the pt-hub package the bluetooth stopped responding. 


It seems like there is a conflict there or a permission issue. 

for easier reading I have taken my posts and combined them in this text file.



txt

1 person likes this
Login or Signup to post a comment