Start a new topic

Using standard Raspbian Jessie on pi-top

I have written a python script to set the screen brightness of the pi-top on standard Raspbian. It is based on the concepts and some code snippets of pi-topOS (thanks to the programmers at pi-top!), but works without any pi-top software. A link to the github repository is attached. Your feedback is welcome. It can be used with the latest and greatest Raspbian.


A link to the repository is attached.

txt
(42 Bytes)

1 person has this question

Hi im having trouble getting Kano os to work on the pi top has anyone managed to pull this off as i cant get sound working through the hdmi to save my life.... any help would be greatly appreciated..

 

Hi Ryan, A fully working Kano OS with sound on the pi-top would definitely be a very nice addition, but there are currently a few roadblocks which cannot be overcome easily. What pi-top and what speaker are you using? The pi-topSPEAKER rev 2 and the pi-topPULSE using the latest pi-top device management software require a later kernel revision as the one the latest Kano beta image can support. Therefore, no chance to use these or the new pi-top laptop at present to get sound on Kano OS. We have to wait until Kano OS is updated to a newer kernel. It might be possible to use the pi-topSPEAKER rev 1 on the pi-top laptop or the pi-topCEED, using a deprecated pi-top driver. If you are interested in that, I could probably get that to work and document it, but only in a few days.

1 person likes this

 Hi Rene thanks for getting back to me i have the older pi top and 2 of the mk1 speakers i have it them both mounted either side of the pi top PROTO dont know if that would be causing issues or headaches when it come to getting it working i have them set to left and the to right be great if i could get them to work with kano as its for my daughter who ahs a presentation planned out to show kids in her class how to use raspberry pi and kano as she loves them, i got her the pi top for her 9th birthday but have struggled to get it running smoothly any help or advice would greatly appreciated :)

ive managed to force sound to hdmi via raspi-config and it shows as hdmi in the setting in kano but still no audio ?

 

Hi Ryan, I think I will be able to get it to work in a day or two on the original pi-top. Let‘s hope for the best. I have 5 granddaughters who would also like to use Kano OS. Let‘s hope for the best. I will post my findings here.
Thank you Rene you are a superstar :)

 

Hi, I installed raspbian on a pi-top desktop for a new project. Everything is fine. But I lost the screen standby option. Does there is a way to set up its screen to automatically switch to the idle mode?
Yes, if you look at github.com/rricharz/pi-top-setup everything is described there.

Hello. thanks for your fast reply and your work. I gave a try on a fresh Raspbian install. It makes the "pi-top Configuration" mena available. But when moving the slider to adjust the delay ; a re-opening of this configuration window displays the slider on 0 value... Not working. Can't figure out why.

I‘m sorry to hear that. Something must have changed in the latest device management software from pi-top. Unfortunately I am unable to test or change anything before the end of July. You can try to use in the mean time the command pt-brightness. If you type „pt-brightness -h“ you should get the options. There was an option to change the screen timeout in the past.

Hi. Thanks for your support. After activating SPI, the slider is working properly. But I can't get the backlight turned off. Do you have a solution?

Can you turn off the backlight with the proper option using pt-brightness? Does the command pt-devices work and does it identify your device?

I am unable to turn of the backlight using pt-brightness. That will solve my concern about energy saving.


When I launch pt-devices, this is what I get:


$ pt-devices

Devices and peripherals handled by pt-device-manager:

OS release: 4.14.34-v7+

Unknown host device

Unknown host device means that the pi-top software does not recognize that the Raspberry Pi is connected to a pi-top desktop. It cannot talk to the pi-top hub board using spi. Most likely this is caused by a wrongly connected gpio cable (the 40 pin cable connecting the Raspberry Pi and the hub), a broken or bent pin on the 40 pin connector or another hardware fault. As long as pt-devices does not recognize the pi-top host, nothing will work. It is also essential that spi is enabled.
Thanks for your very accurate information. I disconnect the 40 pins wire, unplug the power plug, reconnect everything and it is working like a charm. Pt-devices recognize pi-top. Miracle. Backlight off...

1 person likes this
Login or Signup to post a comment