Start a new topic

OpenGL driver and Pi-topOS

has anyone else tried to use the OpenGL driver which is available in the latest Pi-topOS?

A few months ago when Raspbian Jessie introduced the GL driver, I tried it with Pi-topOS using the raspberry Pi 2 B...  My results are

the Pi-top took forever to boot up.

the splash.mp4 that plays while the pi-top boots moved frame by frame.  As soon as the MP4 finished, the Pi-top rebooted itself and started the process over.

I am curious to know if anyone else has gotten a successful boot of the Pi-top with the OpenGL driver. (w/ Pi2B or Pi3B installed)

I just attempted starting the OpenGL driver again on Pi-topOS

sudo apt-get install xcompmgr libgl1-mesa-dri

followed by going into raspi-config and enabling the GL driver.

after a reboot I get:

the rainbow splash screen.

then the screen goes blank and stays that way until I am forced to shutdown the pi-top buy holding the power button.

so the OpenGL driver is still not ready for the pi-top I guess.

I tested the OpenGL driver on Raspbian Jessie with the Pi-Top Hardware successfully.  It seems to work.


it set the Raspbian desktop  over to the left side of the screen and left a third of the right side black and not useable.   I haven't bothered messing with any settings to try and correct this.

newest Raspbian Jessie (9-30-2016)  seems to work with OpenGL activated... but....

the daskboard doesn't work at all.

still testing.

Any news on this? I would like to use on my new pi-top, but right now it's not working.

Hi everyone,

Still the same question: is there any fix to use OpenGL with pi-top (I'd like to use OpenSCAD) ?

I haven't tested OpenGL since the last time I posted.  I left the instructions on what to do above. If you wish to test it.

1 person likes this

Thank you Jesse, 

I am a little bit anxious to try, since I am not sure to understand how complicated it is to return to original config if it does not work.

I understand from your previous posts that OpenGL can be activated/deactivated from raspi-config, and there should be not need for uninstall. But how to proceed if the whole display is messed up ? (remote commande line ?)

I had to revert by ssh-ing in from another computer. It wasn't hard to do, but it's a bummer that Open-GL isn't working on the pi-top. I'm not sure why that is, considering it works for other pi set-ups. Maybe it's the screen driver?

OK, I'll try that during the week-end since I have a lot of things to check first: back-up, ssh, ... and I'll keep you informed.

Since it works on other pi set-ups, do you know where I can find a comparison chart between pi-top OS and plain raspbian ? (pkg installed, systems set-up differences etc ?) It is maybe worthwhile to try with an external screen ?

all you have to do to turn it off is remove a line from /boot/config.txt

I got it working (with the dashboard nonfunctional)  by using the vc4-fkms-v3d.dtbo with a manual edit to the text file I just mentioned.  not the "fkms"  normally you activate the driver and it loads "kms". s after activating the drive in raspi-config go it into /boot/config.txt (I put the pi's SDcard into a windows pc to perfom the edit. and then reboot.

the line in the config.txt will read


change it to



if you want the dashboard back and he driver disabled,  slip the micro sd card into a reader, put the card into a pc or mac and delete the above line from the /boot/config.txt file. Afterwards put the micro sdcad back in teh pi and ereboot.  all will be back as it was without the 3d driver.

I beleive this is something to do with the pi-top screen, yes.

good luck

Jesse.  Is this stable for you? (excluding dashboard)
Have you tried on Jessie Pixel?

I've found minetest to be a great openGL program to test with as it seems to push that GPU really hard.
The version in the repo is stable on the Raspberry Pi3 and I've had it working with an external monitor.

1 person likes this

I have no idea about stability.   I am just trying to get.Pi-topOS pixel to boot with openGL.  I haven't tested any openGL programs. 

I did as mentioned above and have the Pixel screen up with a mouse.

No menu bar at the top.

No way (that I can see) of running any programs.

This his as far as you got previously?

I try yesterday my luck with OpenGL driver and Pi-topOS (an new Raspbian Stretch based version).

I did it because I compiled the application CubicSDR on raspbian to play with Software Defined Radio (with an RTL-SDR-USB-stick) on the pi-top2. I got CubicSDR running but it runs unusable slow without OpenGL enabled.

So I tried the vc4-kms-v3d and vc4-fkms-v3d. Both drivers worked and CubicSDR runs fast. But only with standard raspbian desktop works with the drivers. The dashboard of Pi-topOS was not working at all and stays invisible all the time. :-(

I hope the dashboard of Pi-topOS can be fixed one day to work with the OpenGL drivers so that I can use applications that need OpenGL and the dashboard at the same time without need to reconfigure and rebooting between using them all the time.

Login or Signup to post a comment