Start a new topic

Pi-TopOS: latest raspbian jessie update breaks shutdown menu

Before I get started with detailing this error: let me start by saying that I also got this error when I did a fresh install of Pi-topOS Jessie and did the update and upgrade procedures.

the updates for pishutdown received on 5-20-2016 appear to break the raspbian based shutdown menu.  if you run sudo apt-get update && sudo apt-get upgrade (oddly enough, this latest upgrade give you the same packages as if you did a sudo apt-get dist-upgrade) and pishutdown will be in the  list of packages to be upgraded, If you continue with the upgrade, you may experience the following issue:

upon clicking shutdown from the LXDE menu, the shutdown menu will pop up as normal, but if you click on shutdown or reboot, they will do nothing.  Exit to command line works, but you have to then shutdown from the switch user session screen. 

shutting the system down or rebooting from the buttons on the pi-top dashboard still works as do the shutdown and reboot commands typed into the terminal window. 

1 person has this problem

one thing I didn't mention,  the test with  the fresh install was done with the 8GB card that came with the pi 3 B.  It had only been used to copy to an image I could use on a 32GB card.  For the test,  I put the 8gb card into the pi-top, booted it, then updated it.  I then tried to shut down the systems as mentioned in my post above with the same behavior from the raspbian based shutdown menu. Meaning the Shutdown and Reboot options did nothing.  I could Exit to command line or close the menu, but as a way to shutdown or reboot the system, that menu, that menu was useless for this test.


Jess, The pi-top shutdown system is based on system v. The latest jessie upgrades to systemd, which is a different bootup and shutdown system. Therefore, the shutdown does not turn the pt-hub controller off. Also, several menus including the shutdown menu have changed and do not work properly anymore after upgrading the pi-top software to the latest version. As far as I can see you have two options: 1. Wait, until pi-top releases new software which is compatible with the newest jessie. 2. Use standard jessie and install the programs necessary to control the pi-top hardware from my github repository (see the separate topic). My software has been written from scratch for the newest jessie. If you have any more detailed questions ns, just let me know.

okay thank you Rene.  I just completed backups of both my Pi-TopOS image and the Raspbian Jessie Image I just started working with.  I will put the Raspbian Image back on the SDcard for now.  Until the Po-Top Team is done with the changes to the Pi-TopOS.

just tested this with the newest Pi-topOS with the dashboard updates.  Problem is solved ... sort of...

I did a fresh image of Pi-topOS Jessie from the 6-21-2016 image. 

I ran

sudo apt-get update && sudo apt-get upgrade

after doing this I could still use the shutdown/ reboot/ exit to command line menu from the menu bar . and it still worked  However,

after I ran

sudo-apt-get dist-upgrade

the shutdown menu stuppoed working and I had to shutdown from the dashboard (worked only sometime), or type sudo halt in a terminal (worked always)

after thist test I guess I am going to re image both my sd cards yet again and just not use sudo apt-get dist-upgrade. 

I don't kow if sudo rpi-update breaks the menu or not...  watch this space and I will test.  

sudo rpi-update does NOT break the pi-topOS shutdown menu.  so for now, do NOT use sudo apt-get dist-upgrade, at least until pi-top OS moves over to the system as raspbian has.

Jesse, Just a little bit of technical explanation for your findings. If you type 'sudo apt-get update', it it updates what it can without causing problems, and lists packages as 'hold back' which might cause trouble. I have seen some being held back when I tested pi-topOS a week ago. If you type 'sudo apt-get dist-upgrade', these are loaded anyway and will cause problems. This is of course only reliable if all programmers have described their dependencies properly.

Thank you, for the explanation Rene.  I will remember.

Login or Signup to post a comment