Start a new topic

No Desktop on boot


I seem to have a similar issue to someone else, but I could not post on that thread, where the Pi Top does not make it to the standard Linux boot up screen (drivers etc).  I get a blank screen.

I have included a picture of my Pi Top, just in case one of my connectors don't look right to an expert.


(3.25 MB)

4 people have this problem

You can disconnect the 40 pin gpio connector from the Raspberry Pi just in case there is a problem there. The pi-top can boot without it. Make sure the hdmi connectors and the sd card are all the way in their connectors. What do you observe on the two LED's of the Raspberry Pi?


40 pin unplugged from the RasPi end.  check

HDMI cables, I redid them a couple of times.  Pushing them in as much as I could.

powered on...

1. red and green both on for a few seconds

2. red stays solid on.  green blinks a few times then goes off.

3. red stays solid on.  after a few  more seconds the green blinks a few times then goes off.

Thank you.

Looks fine. Have you checked the connector between the hub board and the screen? Other possible options: Connect a monitor orTV to the hdmi. Try to increase brightness with the key on the keyboard (40 pin connector needs to be connected, wait a minute after boot and try). Maybe somebody else has another idea.

Make sure the hub is seated good into the socket. Seams like you did everything else except create a ticket on it. Perhaps try a fresh install of Raspian on a different card?

I have tried to get my display on my newly created Pi-Top to display something and have run out of ideas. I know the keyboard unit is working, the pi boots correctly (when I connect my HDMI monitor to it is works fine). The bright-dark button on the keyboard does brighten/darken the display but no display (apart from the powered-up glow) results. 

My school bought two (a green one and a grey one, with the possible view of buying class sets of these machines) and the first PiTop (green) assembled fine, but was missing the RasberryPi, SD card and power flex in it's packaging. We used one of our other R-Pis and it works fully. 

The grey one arrived complete, we used the same construction method but the screen is devoid of words.

I am concerned about build quality, dispatch checking and level of support so far - hopefully we will get at least a response about the missing items - not sure how to move forward on display issue however - created a ticket, fingers crossed

I have contacted Piu-Top support and have begun a process of remediation - all very promising

Well I will mirror some of Peter's concerns - but pi-top team responds fairly quickly to tickets raised ! I am still abit concerned about lack of updates and communication on the forum from pi-top - this is though unfortunately a common mistake in startups !! So remember IT IS GOOD TO TALK !! ;0)
I'm having the same issue... any luck?

Same issue with at least 2 out of 8 purchased pi-Tops. 2 worked fine, next 2 blnk screens. I have done all suggested checks above without success.

Same issue here.


I have something similar - I downloaded to a regular SD card and put into my regular pi hooked up to my home monitor. First few times I booted and though the screen initially picked up something I never got to the pi boot sequence. 

Then I went into the config settings and commented out the force HDMI over DVI and viola, the boot sequence came on. However, I'm now not able to get past the pi-top branding screen which appears directly after boot.

yeah, me too.  the polaris screen is displayed, then the black "pi-top" screen,
then the white "pi-top" screen with the "Get Started" button.  Then it stops. 
The touchpad and keyboard do not work either but the green led on the pi

blinks occasionally.  i burned the latest image on a new sd-card but the same thing happens. 

Same issue with me.  Brand new pi-top out of the box.  No video.  I connect to a monitor and all is good.  The display gets power (I can see the backlight on) but no video. :( 

1 person likes this

Hi guys,

   I am having the very same issue. No video, everything else is working fine including blacklight adjusting button... I opened ticket and currently in process of going back and forth with support team...

Can you guys share with me how your situation turned out? How did you resolve it?

Login or Signup to post a comment