Start a new topic

Pi-Top does not turn on

Our Pi-Top seems to have something wrong with it - it will not turn on :(

I have been having a rather unproductive back and forth with support, so I figured I would reach out to you guys to see if anyone may have had this problem before.

Here is a brief overview of what we have tried so far.


Pi-Top will not turn on. No indication of any charging or power to hub is visible. 

Things we have tried: 

- Left it plugged in for hours, despite no signs of it charging as described in the manual ( the pulsing power button never comes on).
- Make super duper sure that all connections are in place as per the manual (We have done this 3x just to be 110% sure this was not the case). Paid extra attention to the hub where it joins the battery, the connection to the screen, and the connection to the power button. No dice. 
- Hold down the button for 3 seconds - tried this at least 20x :(
- Manually push the barrel jack from AC adapter into the hub's power connector, to make sure that it is fully seated ( recommendation from pi-top support)
- As a desperate measure, we remove hub from pi-top, and plug it into the AC adapter, on the off chance that something with the battery was preventing boot. 

- Test AC adapter with multimeter to make sure it is working correctly.

Questions that we have:

- Has anyone else had a problem like this, where the computer does not start at all? 

- Under normal operation, should LEDs on the hub light up when it is plugged in?

- Should the pi-top work if the hub is disconnected from the battery and attached to the AC adapter? 

- One person from support told me to try the manual button on the hub - but my hub has no button (pic)! I saw from research online that perhaps a previous version had some buttons on it (1 green and 1 red pushbutton). The hub I have does not have them, or anything button like that I can see! Am I missing something? 

Any help would be greatly appreciated - it's been almost a week now since we built it, and my son and I were very much looking forward to it. 

Many thanks, 


I have similar problem that PTC doesn't turn on by power button but RPi3 boots itself by micro-USB and HDMI cables only connected to PC's USB input and its monitor with HDMI input of course. I have applied a ticket to support team already but no answers after 2 days. 

Sounds like we are in the same boat - something wrong with the power hub. When you plug in the AC adapter, do any lights turn on on the power hub? 

Yes, it blinks slowly on few seconds delay after I plug power cable into hub power input but power button doesn't react to run RPi3 and screen. I have already tried to move a hub to sides a little bit to make better connection on possible loosen connections as reported some other user on that forum that has bad power connections on hub and it betters by moving a hub but no improvement. I can run RPi3 only by PC, it's some how slowly, CEED universe game loads a very long time. I have USB keyboard and mouse connected on it.

I wonder if they tested working at all.

Probably something different than mine - my pi-top has no lights blinking anywhere :( 

Hopefully we can get some answers – no answers on my ticket either. 

I don't see your file in Tickets above. I see only my ticket. Like there is no one else with filed problems. There is only a post in forum about your problem. I have posted also first on forum and after someone answered that I need to put ticket on support site: Tickets I have file a ticket.

When I plug in my Pi after a moment the green light (on switch) pulses like it should, I press the on-switch on for a couple of seconds, the screen turns on (well, activates - no image, just brighter than off), the Pi power light and green light come on, green light comes on and off but no visible activity on screen - what have I done wrong?

1 person likes this

It's probably something wrong with hub and its connections to RPi3. My PTC doesn't start either at all but RPi3 runs itself by USB power and HDMI on PC screen. Hub only blinks but no power boot on RPi3 after pressing power button on case or directly button on hub. I have filed ticket and I see now that is visible only my ticket, from others is not, and even that one is closed by support team that gave me only 2 responds in 2 weeks. It seems that bad manufacturing is present at a lot PTC backers on Indiegogo.

I have tested the pi in isolation, and using the power from from the hub - seems the HDMI feed to the screen is not working (it is powering the screen but not displaying anything) - if I jack my HDMI monitor into the system seems everything else is working. I gather their "user built" disclaimer means they will do nothing about this sort of issue?

I have created a ticket - will see if that generates any help

A small update - I got in touch with support by emailing them, and they were very friendly and responsive. I will update if they come through. Fingers crossed!

Good news: issue solved - it was the shipped HDMI cable - all else is working well.

Now to find a replacement cable that is so small

I have the same problem as Agustin.  The power cable isn't connecting to the power supply because there's an 'on'/'off' indicator light on the plug, but it doesn't light up when I plug it into the wall.  So can't start my new pi top ceed either  What a let down after waiting so long to get it!


I received an address to a google form process that allowed me to type in the missing items but as yet have not had confirmation of receipt or any idea if the missing/faulty components will be replaced. 

We (a school, considering a bulk purchase) ordered a green and a grey PiTop. The green one shipped without it's Pi-Top or SD card, the Grey one shipped with a faulty HDMI cable.

Oddly, we did however receive 2 Pi-Top speakers and 2 prototyping boards over and above the 2 of each we ordered and already received - hoping some sense appears and we can actually use the gear we received soon. Do not want to consider other options but ..

I wanted to update to say that we received our replacement hub in the mail, plugged it in, and it is working! As I suspected, the hub I received initially was defective. 

For anyone else with a defective component, I think that the best course of action is to send an email to support, and to prepare a quick video showing the problem you are experiencing (they may ask that you share this with them). They will provide you a link which you can use to request a new part. From there, just keep an eye on the mail. 

It seemed that in my case there was some problem with the courier, because my first package did not arrive (I even gave it a few weeks extra). When I told the support team about that, they sent me a new one, which arrived right on time as promised.  

1 person likes this
Login or Signup to post a comment