Start a new topic
Solved

Pi-Top does not turn on

Our Pi-Top seems to have something wrong with it - it will not turn on :(

I have been having a rather unproductive back and forth with support, so I figured I would reach out to you guys to see if anyone may have had this problem before.


Here is a brief overview of what we have tried so far.

Symptom:

Pi-Top will not turn on. No indication of any charging or power to hub is visible. 

Things we have tried: 

- Left it plugged in for hours, despite no signs of it charging as described in the manual ( the pulsing power button never comes on).
- Make super duper sure that all connections are in place as per the manual (We have done this 3x just to be 110% sure this was not the case). Paid extra attention to the hub where it joins the battery, the connection to the screen, and the connection to the power button. No dice. 
- Hold down the button for 3 seconds - tried this at least 20x :(
- Manually push the barrel jack from AC adapter into the hub's power connector, to make sure that it is fully seated ( recommendation from pi-top support)
- As a desperate measure, we remove hub from pi-top, and plug it into the AC adapter, on the off chance that something with the battery was preventing boot. 

- Test AC adapter with multimeter to make sure it is working correctly.

Questions that we have:

- Has anyone else had a problem like this, where the computer does not start at all? 

- Under normal operation, should LEDs on the hub light up when it is plugged in?

- Should the pi-top work if the hub is disconnected from the battery and attached to the AC adapter? 

- One person from support told me to try the manual button on the hub - but my hub has no button (pic)! I saw from research online that perhaps a previous version had some buttons on it (1 green and 1 red pushbutton). The hub I have does not have them, or anything button like that I can see! Am I missing something? 


Any help would be greatly appreciated - it's been almost a week now since we built it, and my son and I were very much looking forward to it. 

Many thanks, 


A


After a little bit of a wait, we finally received all the bits necessary to make our 2 PiTops fully functional. I found the process of getting help a little difficult but in the end all good. Emailing support is certainly the right first step

I have a defect hub as well and have been waiting for 2 months to get a replacement.

I openend a support ticket but it was just closed without a solution.

Which e-mail adres have you used or did you also just open a ticket?

I have opened a ticket right after problem occured and it was closed down without solved status after few days but their support send me questions and evidences about problem and after 2 months they agree about replacement of hub and I'm waiting for it about 2 weeks.

hi all, 

has anyone had any issues with the power supply?

I have tested the output straight from the male dc power socket and get zero volts.

Login or Signup to post a comment