Start a new topic

Setting up the pi-top speaker

 Hi,


 i got my pi-top Ceed and the Speaker this week. Is installed the package and set the speaker to mono. I2C is enabled and the Ceed was rebooted. Than I wanted to play music with the omxplayer. Tried both normal and hdmi, and I tried the mplayer...


But there were nothing to hear. What can I do, to get it to work?


Thanks.


20 people have this question

Thank you Rene, that fixed the problem!


I think I probably ran sudo apt-get autoremove after updating.


Now the speaker works and CEED Universe is working too!


Thanks Rusty. We have found an important addition to the instructions for debugging speaker problems. I am updating them right away. Your contribution is appreciated very much.

2 people like this
Renee,

Oops. Correction on battery life. PIXEL has just advised I've got 15.0 hours on full charge. PIXEL must be easier of resources. It surely boots much faster.

Bye

 

J`ai installer les enceintes Pitop CEED et installer mais elles ne fonctionnent pas. Pas de sons sous PITOP OS meme avec la derniere version. Je trouve qu il manque beaucouq d`information, manuel  ou un tuto pour l`installation. Je suis vraiment pas satisfait du manque de support technique. Cordialement

The instructions (including the latest version of pi-topOS) are at

github.com/rricharz/pi-top-install/blob/master/speaker.txt

Hello,

I own one of this PiTopCeed with jumper cable and there is no connection to the I2C pins.
Can I use the PiTopSpeaker ?


 


1 person likes this
The i2c lines between the 40 pin connector of the Raspberry Pi and the hub controller board need to be connected. Otherwise the speaker will not be properly initialized.
I opened a ticket to the support and they told me that on my version with jumper cable the speaker uses the HDMI sound. But what I have to set to use it ? Any ideas.

 


1 person likes this
Use the Raspberry Pi configuration program to set the audio output to HDMI.


 

I tried everything suggested here and the discovered that sound output on the Pi is disabled by default. In order to hear anything you need to open a terminal and enter the following: sudo nano /etc/modules Add this line to the script: snd_bcm2835 Save and exit then reboot. You should then have sound. (It worked for me!)

Thanks Trevor for this very helpful information.


We would appreciate feedback from others who were able to solve their speaker problem using this approach. In the mean time I have updated the detailed procedure on how to set up the speaker at

  github.com/rricharz/pi-top-install/blob/master/speaker.txt


2 people like this
Hi guys, back in the subject.
I own the jumper cables version of the Ceed, and thus, i2c pins on the RPi are not linked to the pi-top hub…
I thought that the audio was routed through the HDMI display port, so i thought that it's not an issue.
However when i try i2cdetect -y 1, nothing appears on the grid (i mean i see the grid, but nothing is detected). To be more accurate, i'm using 2 pt-speakers in a stereo setting.
Anyone here owning the Ceed's jumper cable version and who got his speaker(s) to work??
Thanks again to everyone!

 

If you've tried everything suggested here and your speaker still doesn't work, try easing it gently out of the hub a little way and then easing it gently back in again. Mine stopped working and when all else failed to solve the problem this simple action fixed it! 

1 person likes this



Rene Richarz,


Sorry to revive an old thread but I came to this thread looking for a solution to the last problem rusty posted. Namely no sound and the output of pt-speaker being:

gpio: Unable to find i2cdetect command: No such file or directory


I have the latest version of wiringpi and still have the issue. I was able to workaround the issue by changing the call to "gpio i2cdetect" in the pt-speaker script to "i2cdetect -y 1" but that doesn't seem like the best course of action. 


I'll also note that this only seems to occur after you update to pixel. I tested the command "gpio i2cdetect" before the update and it results in the same output as "i2cdetect -y 1" but after the update it is unable to find i2cdetect command. 


Any ideas would be appreciated. 

Try "apt-get install i2c-tools"
Login or Signup to post a comment