Start a new topic

Setting up the pi-top speaker


 i got my pi-top Ceed and the Speaker this week. Is installed the package and set the speaker to mono. I2C is enabled and the Ceed was rebooted. Than I wanted to play music with the omxplayer. Tried both normal and hdmi, and I tried the mplayer...

But there were nothing to hear. What can I do, to get it to work?


20 people have this question

I think you can plug headphones directly into the Raspberry PI. The speaker does not have a headphone jack.. :( 

Thanks to all who helped me get my speakers installed! Never did see that edge connector on the power supply board! That was the bottleneck! 


Thanks Rene (and Nathan), your "gpio i2cdetect" to "i2cdetect -y 1" workaround got my sound working.


I'm a new pi-top owner and just learning my way around... having the same problem with the pitop speaker. Based on these suggestions, I tried installing RRicharz's battery status - here is the last output i get.I also got the "unmet dependenies" error when following the instructions for installing the speaker. 

Any suggestions onwhat else i can try? thanks for this forum!!

pi@pi-top:~/Downloads $ sudo apt-get install wiringpi

Reading package lists... Done

Building dependency tree       

Reading state information... Done

You might want to run 'apt-get -f install' to correct these:

The following packages have unmet dependencies:

 pt-speaker : Depends: pt-aliases (>= 1.0.0-1) but it is not going to be installed

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Hello Melissa

I too had this problem today. Could not solve it.

So I downloaded the last pi-TopOS (2017-04-28-pi-topOS) and reinstalled it to my sd-car. Now everything works. (with this pt-aliases I couldn't get my speaker working). After reinstall the sd-card it worked

Thank you, Christoph!! I had a false start, changed Pis and it worked with a new one, so I went back to my original - had to play around with a few settings, not force HDMI for general sound but force HDMI for Sonic Pi. I now have sound for Sonic Pi. YouTube, and the built-in games... so I think it is all working now! I appreciate your quick response and helpful advice!!


Latest upgrade in jessie broke the speaker yesterday.

Sense HAT (UU) prevents running pt-peripherals-daemon then speaker fails.


I successfully had the pi-top speakers working on my pi-top running raspbian but I must have screwed up something (or a update has gone wierd) because the speakers no longer work.

I see the speakers at postion 71 & 72 with i2cdetect and the /etc/modules and /boot/config.txt have not changed.

The conclusion I have reached is it is due to the pt-speaker package no-longer containing the /usr/bin/pt-speaker command:-

dpkg-query -L pt-speaker








No "/usr/bin/pt-speaker" anymore :(

running a system-wide find for "pt-speaker" only returns:/usr/share/doc/pt-speaker.

Any idea what could have happend and how to resolve it?

Thanks in advance,


Look for pt-peripherals-daemon. Be root.

Hi, I got a pi-top and I'm trying to get my speaker to work. I'm using Raspbian Stretch. I wrestled with it for hours yesterday, until finally shutting it off, removing and reinserting the speaker. I turned it on and it worked. All seemed fine. Now I turn the pi-top back on today, and NOTHING again.

The reinsertion trick didn't work this time. This is absolutely freakin' maddening, and for the price of this stuff, I expect it to be MUCH better implemented. Ridiculous! I'm not happy with this company.

All that being said, can anybody help me? I've already done everything in Rene's readme file. It doesn't work. pt-peripherals-daemon says it is enabling the speaker if I run it manually as root, but it doesn't help at all.

I'd like to believe I'm not technically inept. I am a software engineer by trade! Mostly embedded software. It shouldn't be this difficult to get the speaker working, guys.

What should my /boot/config.txt settings be? I'm pretty sure they're set correctly, but I could be wrong.



I feel your pain. This spring, I spent hours trying to get the speaker to work. Finally re-installed everything from scratch. It worked. A few weeks later, was using the PiTop to show off Sonic Pi to my brother the sound recording professor (I just bought him a raspberry pi 3B and some music-oriented HATs) - it failed. Very frustrating since I was trying to show how cool RP3 can be! Then spent the summer getting it working again. Last week I brought my pi-top to school to show my high school students this cool device and how we can learn programming and do sound with it - and the speaker failed. In the meantime, I cannot get the protoboard to work properly either (kind of the whole reason I bought a pitop laptop kit for my classes, to make it easier to have the breadboarding right there where they code the circuits). Sooo frustrated and quite frankly hardly have the energy to try again. I could've bought 3 or 4 finished arduino-based robotic cars or twice as many robot kits for what I have spent on the pitop.


Hi Melissa. Yeah, that must have driven you nuts. I mean, the system generally works well, and makes a great ARM-based laptop with pretty decent performance and amazing battery life, but there are so many times when you need a speaker. Very frustrating to have one key piece of equipment not working in an otherwise very cool piece of hardware that makes a great conversation piece around other tech-minded folks.

If I could get it working, I could actually see this being my main daily use laptop. What a shame!

Hope this is of help to any of you.

I was having similar problems trying to get the sound working. Tried all the suggestions on here and GitHub without success. Finally I found the answer to at least my situation and maybe you are doing the same.

My Pi-Top's are fitted not only with a speaker, but also the Protoboard and SenseHat. If I remove the SenseHat the sound works. I think that this must use the same data lines as the speaker and killing the sound.

I am still trying to get this to work with both boards connected.

1 person likes this
Login or Signup to post a comment