Start a new topic

Setting up the pi-top speaker

 Hi,


 i got my pi-top Ceed and the Speaker this week. Is installed the package and set the speaker to mono. I2C is enabled and the Ceed was rebooted. Than I wanted to play music with the omxplayer. Tried both normal and hdmi, and I tried the mplayer...


But there were nothing to hear. What can I do, to get it to work?


Thanks.


20 people have this question

I assume you have used user pi to install and test the speaker. If not, that's the problem.


If you have sufficient experience with Raspbian, you can try the following to check your installation:


Are the following files present:

/opt/pt-speaker/pt-speaker-controller.py

/opt/pt-speaker/playback.configure

/usr/bin/pt-speaker


Is the the last one (pt-speaker) executable?


Look a /home/pi/.config/lxsession/LXDE-pi/autostart:

Is there a line "@pt-speaker"?

(on a separate line, no empty lines etc.)


Open a terminal again and do the following:

cd /opt/pt-speaker

sudo python pt-speaker-controller.py m


Does it answer

m

Done! Exiting...


If all of this is ok, the speaker is present, set to mono and properly initialized.


Please let me know whether this helped. I would like to improve the setup procedure on github.



1 person likes this
I'm using raspbian jessie.I've tried everything on github and still have no sound. I've follows the directions all the way several times still nothing. When I use pi top os I have sound. But I installed my own card running noobs version of raspbian jessie. Can anyone help?
After a few problems my Pi-Top Speaker arrived today. Gosh, but it is compact. It came supplied with screws to mount in either the Pi-Top or CEED. I followed the Pi-Top instructions but didn't get sound. I then followed Rene Richarz instructions on GitHub. After the last reboot my Pi-Top powered up and I got sound when I started CEED Universe. Thanks for all of your hard work and excellent documentation Rene. Casual users, like me, really appreciate your efforts. My Kermit can now croak. 

2 people like this
Stewart, please let me know what problem you have with the detailed instructions at the link in my last post, so that I can improve the instructions. The reason why they are at github.com is that it is possible there to improve them whenever a user has a problem or a proposal for an improvement. Thanks for your help, and thanks again to all users of this forum who have helped to put this information together.

Please provide  a set of instructions  HERE to get my speaker working here.  Have tired things on box

Thanks 


There is a detailed procedure for the installation of the pi-topSPEAKER in both pi-topOS and Raspbian Jessie available at the bottom github.com/rricharz/pi-top-install
I have done some further investigation into how the pt- speakers work. It is not sufficient to enable hdmi audio output, but the volume of the speaker needs to be set using i2c. See the script /user/bin/pt-speaker, the python script /opt/pt-speaker/pt-speaker-controller.py and the script /opt/pt-speaker/playback.configure

Thanks, 

 

 for your message. I just checked the /boot/config.txt. The line was already uncommented:


# uncomment to force a HDMI mode rather than DVI. This can make audio work in

# DMT (computer monitor) modes

hdmi_drive=2


und when I tried to use omxplayer -o hdmi (what I have already done)  it worked. I don't know why, but it's good that way.


1 person likes this
YOu can try this and let us know whether it works: -/boot/config.txt: Uncomment #hdmi_drive=2. Reboot. -call omxplayer as follows: omxplayer -o hdmi filename where filename is the name of the file to play
Login or Signup to post a comment