Start a new topic

Different controllers than a raspberry pi?

Does anyone can tell me what microcontrolle/boards other than the pi will fit into the pi-top? I might be interested in some more powerful boards, so I would love to know the requirements for the boards!

2 people like this idea

I was wondering this as well. Info says you can use other boards but I can't find specific detailed confirmation. I was hoping to use the ceed setup to play with both Pi and the CHIP.
You can put any board in the pi-top which has the same form factor as the rpi. You just have no brightness adjustment. If you talk about the pi-topCEED, this is ok. But if you talk about the laptop, I do not recommend to use other boards, because you might run into battery problems sooner or later without being able to observe battery status.

So, I'm running an ODROID-C2 in my pi-top laptop, and aside from a slight video issue it works. The Odroid also has the same # of GPIO pins and with Arch, there was even a prog to match the GPIOs up to RaspPi specs.

So, I should be able to run it fully off the Odroid, once I get the video issue sorted. But, same form factor and according to specs, the Hub should be able to output the necessary amperage for higher-powered SBCs

Please tell me how i can use the odroid c2. i try too but i only get a black screen on the pi-topceed. Odroid is bootin and on tv and monitor it worked, but not on the ceed. Can someone help me please?


Sorry to say, I'm having a similar issue. I can't tell where the incompatibility lies. The screen runs off 2 different computers and is recognized immediately, both Android, and Ubuntu for Odroid have the resolution supported, but you're right. I can't get it to actually show visuals for the life of me. Recently, it's started to just not work with my Pi2 running PiTopOS either... So Idk what's happening here. I asked the actual Pi Top support line. No real luck yet. This would be an awesome product if it worked with any pi form factor board. But damn if making it work isn't a challenge and a half.

So it's all about the GPIO pins. This is what we need if we want to use a SoC computer with the CEED. 

Now I will start to search to see the fastest thing that has Raspberry Pi compatible GPIO pins... sorry to hear it sounds like the ODroid isn't matching the Raspberry Pi spec possibly

An interesting idea could be using RTK.GPIO with NUC/Mini-ITX form factor and 12v-5v step down, though it would need alot of rehousing 

IS THE GPIO CONNECTION NECESSARY TO USE THE PI-TOP? The following things are controlled using gpio pins on the CEED and the laptop: spi (brightness, screen off). i2c (speaker filters and loudness). Laptop only: i2c (battery). The hub controller does remember the last brightness/screen off settings. It is therefore possible to use the pi-top without any gpio connection, if the last brightness value was high enough. I see no reason why this should not be possible with the ODROID. If the ODROID does not work, I can think of two reasons: brightness not high enough or wrong hdmi mode. One can check the hdmi mode settings in /boot/config.txt which are used by pi-topOS. I do not know how to set the ODROID to the same hdmi mode. If necessary one could of course also use an rpi zero to set the brightness. If somebody wants to try that, I have all the information needed on how to achieve this.
The Odroid has the same number of GPIO pins as well as WiringPi for the GPIO pins, so I would assume that isn't the issue... The Odroid just can't seem to find the right resolution. I've tried cvt in Arch and I can't even do a custom resolution for it. But every other PC or Pi I try can immediately recognize the screen as a screen. Tried it with Ubuntu as well, same issue. I'm stumped.
The Odroid just shows me a black screen with some scrolling blue/white artifacts. No matter what OS I try and use. Is what I meant by my last line above.
This looks like a screen resolution problem. tvservice -s gives me the following: state 0x12000a [HDMI (81) RGB full 16:9], 1366x768 @ 60.00Hz, progressive. tvservice -m DMT gives me the following: (prefer) mode 81: 1366x768 @ 60 Hz 16:9, clock:85MHz progressive. Maybe this helps you to set the screen mode on your ODROID.

1 person likes this
Now, how are you getting that information? Are you SSH'd into the Odroid or just checking it on a pi, are using an HDMI splitter? Now, of course an Odroid doesn't have pi-top OS, I believe it's a different arm chip, so slightly different rules? I know there were different options for arch, between the pi3 and c2. Also, the boot.ini file, I couldn't find it from inside the OS. Only when I was configuring it inside of another OS through the terminal. Is there a way to access it, or was I just in the wrong directory perhaps?
This is the information obtained with the tvservice command booting a Raspberry Pi 3 with standard Raspbian. This is the HDMI mode which the rpi is using successfully. I have seen searching on the net for ODROID hdmi resolution that there is a lot of information available on how to set the hdmi mode on the ODROID, but I cannot help you with that because I do not have an ODROID. As far as I know the HDMI modes are universal and should be the same on a PC, rpi and whatever other device using the same screen. If you cannot get any further, asking on the ODROID user forum with this information might help.

Alright, so. Update: I was successfully able to access the boot.ini file within the OS. However, I modified my own from a Raspberry Pi2 running Pi-op OS. It'll be in the root directory (cd /) and then the /boot subdirectory.

cd /
cd boot
sudo nano boot.ini

 sudo nano is necessary to change the boot.ini file. Only uncomment the satenev line for "1360x768_60.00" line. You'll have to scroll down to find it. After tha simply remove the "#" symbol and hit "ctrl + x" to save the file. After that reboot your ODROID and give it a second. Mine still gave me artifacts until it got to that line and then gave me the terminal screen (I'm using Arch so mine doesn't start with a GUI), in the correct resolution and visible.

Next orde of business is to get the power managment/screen brightness controls set up. I know it's done through the GPIO so I'll probably have to find the file in pi-top and point Arch at it. Hope that helped someone, and thank you Rene for the help!

Login or Signup to post a comment