Start a new topic

Startup Options

Does anyone know how to make the pi-top start the desktop automatically ?

The dashboard is nice but we want to start in desktop?


Is there a setting or a config 


1 person likes this idea

There are two options:


1. If you want to use pi-topOS:

***************************************

Open a file manager window, go to /home/pi/.config/lxsession/LXDE-pi

Double click on autostart

put a # in front of the following two lines, so that they look like this (careful, change nothing else):

  #@pt-splashscreen

  #@pt-dashboard

Advantage: you can still use CEED universe (in menu games) and the dashboard (with the command pt-dashboard)


2. Use plain standard Raspbian Jessie

*************************************************

Download an image from raspberrypi.org, install it on an SD card

Install programs to handle pi-top or pi-topCEED from github.com/rricharz/pi-top-install

Advantage: newest Raspian, standard for rpi, works with all Raspbian software



1 person likes this

Hi,  I just got my new pi-top CEED and installed the latest OS and I was trying to follow the option 1 instructions to start the pi-top to desktop rather than dashboard. 


After going to the directory /.config/lxsession/LXDE-pt, I sudo nano autostart but got the following:

 @lxpanel --profile LXDE-pt

@pcmanfm --desktop --profile LXDE-pt

@xscreensaver -no-splash

@point-rpi


I would be grateful if anyone could point me in the right direction on how to make the mods to start the pi-top CEED to desktop. One of the main reason is because my bluetooth mouse doesn't seem to work on dashboard, and the VNC viewer on my laptop only shows a black screen when the pi-top is displaying dashboard. VNC works fine on desktop.

Thanks a lot....

Option 1 does not work anymore on the latest pi-topOS
Thanks for the reply. I’ll keep looking.

I have had a reply from pi-top support as follows:


"So to boot directly into the Desktop please open up the terminal,and run this command line in the terminal:


sudo systemctl disable pt-os-dashboard"


When I rebooted, after that it opened Desktop....


it works, I guess if I ever need to enable Desktop is to enable it again...



1 person likes this
Login or Signup to post a comment