Empezar un tema nuevo

Sudden loss of screen brightness

I've suddenly had an issue where my Pi-Top will boot up an then Ill get the Pi-Top loading screen, but the screen will loose its brightness and go nearly completely black (to the point where I cant see my cursor to make changes). 

Any thoughts? 

Has anybody seen this issue before?

3 personas tienen este problema

since a small movement of the mouse is fixing this on my Pi-Top i guess it is a to fast screen saver. :)


No, its definitely not the screen saver. I can still see the text on the screen, but its so dark I can't tell where the mouse cursor is, so it becomes un-usable and it does this almost immediately after the Pi-Top begins to load just after start up.

Im not 100% sure, but banging on it a bit seemed to fix it.  Maybe my mouse pad came loose. 

i do facing this problem too. But, after i update the patch fix send by pi top, the problem is fix. The root cause is due to the setting time out is too fast, therefore there is a patch fix.

I have the same problem. Can somebody post the fix?


I'm coming back to play with the Pi-Top after much frustration. I upgraded to a Pi3 and downloaded the latest PiTopOS. Screen still goes blank after boot up. Moving mouse or pressing a key doesn't help. I do get a message saying the Xscreenscaver is out of date. 

Can some point me to the patch  fix referenced above?

same problem
 need fix?? anyone


Got the same problem, even when running the a latest Pixel..


Are you using pi-topOS? Can you adjust screen brightness? Does the red LED turn off after shutting down with the menu?
I sort of gave up on Pi-TopOS as they said the upgrade caused a previous screen issue. This is Raspian Pixel. It worked   fine for a few days, booted up this am and about 30 seconds after the screen came on as i was about to start typing the screen went to about a .1 brightness , can see the image pi runs fine, but cannot get screen brightness back...


My ceed does this after periods of standby. No amount of waking through keyboard or mouse will wake the backlight although the LCD still shows activity, it's just incredibly hard to see. I tried remounting all power and data cables to video with the pi still on but no joy. A full system power cycle is the only resolve at the moment, hoping it's not a hardware chip bailing on the power board, maybe there is a option for sleeping the screen that I'm missing.
Pi-top was fully updated and working about a month ago (say 1-November 2016) then not used for a month.  Now same dark screen problem as above.  Something has switched the backlight off, or there is an electronics failure, because LCD assembly is partially working - can just see screen after booting up.
Took RasPi out and it's working fine on an external display, put it back and there's still no backlight.
Anybody resolved the problem please?


Brian I have similar issues, spend hours getting the top working then normally just when i am happy, the next boot does not happen! One option was like yours I can see PITop logo as it boots then a faint image on the screen. But not possible to work. brightness  option mostly does not work. Currently using Raspbian instead.
Also had it one day when battery was dead with pitopos but changed to Raspbian and it charged..


Thanks Dave for replying.  Lack of any resolution or interdiction from anyone from Pi-Top is not promising!.

I'm thinking that the Pi-Top team screwed up the last but one update - that I obtained by apt-get dist-upgrade.  During the download the screen brightness suddenly changed - to about maximum I believe, before getting anywhere near kernel updates.  That was the update that installed PIXEL and the new Dashboard.  The Pi-Top team updated pt-hub-controller and lightdm.conf that were changes in the configurable pi-top hub, and it seems they tripped something about backlighting therein, dependencies screwed-up most likely.   Because the RaspPi works perfectly well out of the Pi-Top.   They seem to be aware of this and have issued a complete new Raspbian with Pi-Top extensions - but I've now downloaded that and tried that too and it doesn't reset the hub (or otherwise switch the backlight on again).    

Looks as though we need to get in touch with Pi-Top directly - this forum support is going nowhere. 

2 personas Les gusta esto
Iniciar sesión o Registrarse para publicar un comentario