Empezar un tema nuevo

Battery / Power problems

When my Pi-top is charged I'd unplug it from the wall but immediately the pi top would turn off. For a while all i'd have to do is try to remember to shut down when its charged then unplug it. However, perhaps i forgot to do that one to many times now I get no indication of battery charge, nor does the pi top power up without being plugged into the wall. Its become highly inconvenient and Im not sure whats damaged or how to fix it, what can be done?Thank you very much

22 personas tienen este problema


I am able to run the i2cdetect with the resulting matrix table - all 0's except a 0b in the 00:b address.

I am running the Raspbian Stretch on my pi-top - just did an update / upgrade and still have the same compile errors.



Did you use the accompanying "make" file?

And this to run: sudo ./m_access-4.

I tried a second pi-top and got no errors.

It looks like a missing library to me.

m_access-4c: m_access-4.c
    gcc -Wall -o m_access-4 m_access-4.c -lpigpio -lrt
    chmod +x m_access-4

On my system, both make file and .c file are together in the "downloads" folder.

Hope this solves it.




When I remove "-lpigpio -lrt" from the end of the second line of the "make" file, then I get exactly the same error messages as you get.

Please use the "make" file that sits together with the .c file.

Please let me know how it goes.



Ivo - OK, I finally found where the make file is located and was able to compile. I did receive a warning during compile, but it completed anyway. The warning was

m_access-4.c: In function 'main':

m_access-4.c:305:13: warning: variable 'n' set but not used [-Wunused-but-set-variable]

     int     n;

I ran the program, and received a warning on the third line of output, but it kept running for a bit, now seems to be hung.

Start of output...

*** Texas Instruments bq40z60 status tool v0.9a - 29/07/18 09:25 ***

pigpio initialization OK

i2c open OK

0x0001 Device Type : 0x0046

i2c write command failed

- [1:0] Device Number : 0x0000

- [3:2] Version : 0x0000

- [5:4] Build Number : 0x0000

- [6] Firmware Type : 0x00

- [8:7] Impedance Track Version : 0x0000

- [9] Reserved - Do not use : 0x00

- [10] Reserved - Do not use : 0x00

0x0003 Hardware Version : 0x200


I'm attaching the full screendump here.

thanks again,


For those Pi-Top owners who purchased in the UK, you are covered by the Whitegoods consumer protection legislation though little recognised or used by consumers. This gives you the right to return faulty goods for replacement with non faulty item(s) or a full refund. This does not cover simple wear and tear or breakage due to misuse. This legislation was designed to 'prevent' the dumping of substandard products on the UK market.
Ivo, please advise: After an incredible struggle with Pi admin to get a ticketed replacement hex key for the screen hinges I can finally get to replace the battery pack with one of the replacement units sent to me 6 months ago! I do hope the batteries have not discharged in all this time? My Pi v3b has now been replaced with a Pi v3+, I saw a comment(?) stating a particular OS version is required for the Pi v3+ for hardware compatibility. With respect to rebuilding my Pi-Top is there a guide I can follow to avoid making any mistakes please? If not, where should I look to find the pieces and perhaps compile them to keep up with developments and contributions? With thanks Alexandra
The point about the Whitegoods legislation is that you are covered for a period of 6 years from the date of purchase and replacement. Apology for not making this clear! Alexandra

Alexandra, may I suggest you ask Rene? He's much more the expert about what version of hardware goes with what version of software.

Your batteries, that's another matter. The cells on itself don't drain even not over a longer period. I guess you got a complete new base, and as such the Smart Battery was connected all those months.

On Github there is stuff written by Rene and myself.




Never seen so low a cells:

0x003C CellVoltage4     : 290 mV
0x003D CellVoltage3     : 1013 mV
0x003E CellVoltage2     : 258 mV
0x003F CellVoltage1     : 1080 mV

"Precharge" won't help either, far too low.

I'll upload a newer version of my tool later today.




I found the new version and compiled / ran. The program completed normally. Note, I also burned a new image of the latest Polaris OS and am running on that now. It seemed to help with the i2c reads/writes - didn't get any errors in the program run. Attached is the output.

What do I do now? Should the batteries be charging now or is there anything else I need to do? The little battery icon in the bottom right says "Charging: 0%" (but has been on 0% for about 10-15 minutes now...)




It looks grim:

- all 4 cells are far below 2500 mV

- balancing does not work in v13 of the SBS firmware

- SBS cannot be uncoupled from the cells

- SBS firmware is password protected

How comfortable do you feel handling multimeter, adjustable labo power supply both for tension and current?

Do you hold a degree in Electronics, either trough schooling, on the job training, amateur radio, ...



Ivo - I'm comfortable w/ multimeter and power supplies. Don't have an adjustable one, but can probably put my hands on one from a friend. My background in electronics is mainly from my tinkering at home. I'm mechanical engineering by schooling and trade - with some basic electronics thrown in. I've designed and prototyped some basic boards for the various projects I've done around the house. (AC / DC motor control, sensors, programming...)

I'm viewing this as a learning exercise mainly - I have a replacement battery already on the way from pi-top. So if I end up frying my existing battery, no big deal... If you're OK with providing some direction and pointers from your own experiences, I'm willing to do some tinkering.


Kenneth, my amateur radio callsign oscar november four india victor uniform at uba dot be.



Im Westen nichts Neues


Both my pi-top v1 and v2 run perfectly, not a single glitch.

I often let them deplete their battery packs without an issue.



So, I've pulled my 'old' Pi-top 1 from the cupboard to prep it for my son so he can tinker with coding. It had been sitting there for 18 months...

The battery isn't charging and I've run Ivo's tool (first time successfully compiling something, yay!) to find out what the details are of the battery cells (full report attached):

0x003C CellVoltage4                                                : 384 mV

0x003D CellVoltage3                                                : 0 mV

0x003E CellVoltage2                                                : 0 mV

0x003F CellVoltage1                                                : 2972 mV

0x004F State of Health                                             : 100 %

2 cells look quite dead (although the SOH thinks it's at 100%, lol), but if there's anything I can do to try and revive them. please share what that would be. 

Alternatively I can try to replace the battery. The honcell link to the batteries manufacturer in Ivo's GitHub files isn't working anymore, so a replacement would either have to come from Pi-top (awaiting their response to my request as we speak) or a 3rd party. Any pointers in that direction are also much appreciated.

Looking to breathe some life back into the old machine, because a laptop that needs to be on a cord 24/7 loses its purpose.


(3.77 KB)
Iniciar sesión o Registrarse para publicar un comentario