Empezar un tema nuevo

Pi-topOS Jessie - expand filesystem fix

Here is the problem I encountered with pi-topOS Jessie:

I loaded the Pi-topOS Jessie onto a 32GB micro SD card.

 first thing I did was to sudo raspi-config and try to expand the filesystem. It didn't work at first it came back wiht the error:

/dev/root does not exist or is not a symlink. cannot expand filesystem. so I tried making the simlink;

sudo ln -s mmcblk0p2 /dev/root so I ran raspi-config again and expanded the filesystem. It said the filesstem was resized. After a reboot though, the partition wasn't resized.

Here's the Solution:

put the SD card into a pc running linux and run gparted:

select the SD card in devices notice the ext4 partition with a yellow square beside it's partition type.

 Select it. then go to partition in the top menu and select Check.

the partition will be resized properly. You can then put it backk into the pi-top. I don't know why this happened, but I thought it might be useful for you.

---Jesse Moore

Or use gparted to expand the partition before putting the card into the Pi.


I did not have a linux system available but was able to use gparted on my pi-top.

I was using a usb SD card reader to hook up the SD card, which needs to be fixed and expanded.

(this post was edited several times because it seems to have been lost in deep space)

Expanding filesystem on your Pi-Top,

Start fdisk
sudo fdisk /dev/mmcblk0

You can view the existing table with p.

p to see the current start of the main partition

Then delete partitions with d and create a new with n.

d, 2 to delete the main partition
 n p 2 to create a new primary partition, next you need to enter the start of the old main partition
131072   (on the pi-topOS-jessie-pi3.img date 9-3-2016)
and then the size (enter for complete SD card).
 w write the new partition table

Now you need to reboot:

sudo shutdown -r now
After the reboot you need to resize the filesystem on the partition. The resize2fs command will resize your filesystem to the new size from the changed partition table.
sudo resize2fs /dev/mmcblk0p2

When it is done, you can check the new size with:

df -h


1 Persona Te gusta esto

In fact Ext4 partition expansion as described in the original post can also be achieved by some Windows-based applications. I have done this many times in my work with various RPi SDcard images, using the free versions of "Paragon Partition Manager". This allows you to do the expansion in a normal Windows GUI, without need for command-line complications. But of course, as always with programs modifying partition data, you still need to be very careful in selecting the proper drives and operations.

I believe there are some more tools which can also do this under Windows, but that one is what I've used many times myself, always with good results.

Best regards: Ulf Ronald Andersson (aka: dlanor)

Pi-topOS-Jessie-21-6-2016 still requires the fix I explained in my first post.  I am beginning to wonder if it is not an issue with the missing symlink plus a problem with my 32GB sandisk extreme MicroSD card..

I feel like I am the only one experiencing this issue, but I know I can't be. 

 and I am betting that the fix would be easier to do with our 8gb cards as the main disk on the pi, install gparted on that, and plug the larger sd cards in through a usb adapter and run gparted and perform the steps I outlined in the first post.  if I have to re image the 32gb card again I will try the fix using this method and see how weill it works

I get this on my 16GB Samsung micro-sd card too. Thought it was just me!

Exact same error message. Is this a bug in Jessie or the pi-top tweaked version of it?

is there a way to do this on windows?

Iniciar sesión o Registrarse para publicar un comentario